summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAndrew Oakley <aoakley@espial.com>2015-01-27 17:18:13 +0000
committerBryce Harrington <bryce@osg.samsung.com>2015-01-28 21:29:10 -0800
commita4afd90f9f0c27ed5f3f313b915c260673f8be34 (patch)
treecf74acf3b688a75dfed37be7b168156688f5b664 /Makefile.am
parentcd0cf5a106b0578da9706f9eb3ceac3ff07c26ee (diff)
configure.ac: use pkg-config to find expat
This is now done in the same way as the libffi dependency and still allows the library to be installed in a non-standard location (with PKG_CONFIG_PATH).
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 43b741a..0fccf86 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -65,6 +65,7 @@ if ENABLE_SCANNER
wayland_scanner = $(top_builddir)/wayland-scanner
bin_PROGRAMS = wayland-scanner
wayland_scanner_SOURCES = src/scanner.c
+wayland_scanner_CFLAGS = $(EXPAT_CFLAGS) $(AM_CFLAGS)
wayland_scanner_LDADD = $(EXPAT_LIBS) libwayland-util.la
$(BUILT_SOURCES) : wayland-scanner
pkgconfig_DATA += src/wayland-scanner.pc