summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndoni Morales Alastruey <ylatuya@gmail.com>2012-08-09 19:20:19 +0200
committerAndoni Morales Alastruey <ylatuya@gmail.com>2012-08-09 19:22:14 +0200
commiteb1da63ade8d93775199e5a10103d534beddbcd1 (patch)
tree92c7cd92b2eb09660bc48146bde32995680b002a /configure.ac
parent7c44fea98d8c8bc025f5e3dc77ea1ac4af576886 (diff)
vp8: fix configure check for windows
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c725b82d6..bcaa75abe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1776,6 +1776,12 @@ AG_GST_CHECK_FEATURE(VP8, [VP8 decoder], vp8, [
PKG_CHECK_MODULES(VPX, vpx, [HAVE_VPX="yes"], [HAVE_VPX="no"])
if test $HAVE_VPX = "yes"; then
+ dnl on windows platforms libvpx can only be compiled statically
+ case "$host" in
+ *ming*|*cygwin*)
+ VPX_LIBS=`$PKG_CONFIG --static --libs vpx`
+ ;;
+ esac
HAVE_VP8_ENCODER=no
HAVE_VP8_DECODER=no