summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRaimo Järvi <raimo.jarvi@gmail.com>2011-06-07 13:55:38 +0300
committerDavid Schleef <ds@schleef.org>2011-06-25 18:08:45 -0700
commit59aaf71b0bc2534a082e423064b9d2fe095abc59 (patch)
tree1cee3ebcfd40ec17431e07d4b698b28b83952d64 /configure.ac
parent40ee3369a0e0c555e94cdec06ab8b1303ca3c094 (diff)
d3dvideosink: Fix configure check and makefiles
Fixes bug #652035.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 4 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 4e4155388..da0305baf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -463,16 +463,15 @@ AG_GST_CHECK_FEATURE(DIRECT3D, [Direct3D plug-in], direct3dsink, [
save_LIBS="$LIBS"
CFLAGS="$CFLAGS $DIRECTX_CFLAGS"
LDFLAGS="$LDFLAGS $DIRECTX_LDFLAGS"
- LIBS="$LIBS -ld3d -lgdi32"
+ LIBS="$LIBS -ld3d9 -lgdi32"
AC_MSG_CHECKING(for Direct3D LDFLAGS)
AC_LINK_IFELSE([
#include <windows.h>
-#include <d3d.h>
+#include <d3d9.h>
int main ()
{
- GetStockObject(0);
- Direct3DCreate(NULL, NULL, NULL);
+ Direct3DCreate9(D3D_SDK_VERSION);
return 0;
}
@@ -485,8 +484,7 @@ int main ()
LIBS=$save_LIBS
if test "x$HAVE_DIRECT3D" = "xyes"; then
- dnl this is much more than we want
- DIRECT3D_LIBS="-ld3d -ldxguid -lgdi32"
+ DIRECT3D_LIBS="-lgdi32"
AC_SUBST(DIRECT3D_LIBS)
fi
AC_SUBST(HAVE_DIRECT3D)