summaryrefslogtreecommitdiff
AgeCommit message (Collapse)AuthorFilesLines
2013-08-15xinput: Add XI v1.5Daniel Martin1-1/+125
New: - Requests * ListDeviceProperties * ChangeDeviceProperty * DeleteDeviceProperty * GetDeviceProperty - Enum * PropertyFormat - Event * DevicePropertyNotify The requests ChangeDeviceProperty and GetDeviceProperty use switches to return a list depending on the format (8bit, 16bit and 32bit) of the property value. We reuse the <bitcase> here. Which is possible, because the format values don't have equal bits. But, this is rather a hack and must be changed when the value test (a <case>) for switches is implemented. Signed-off-by: Daniel Martin <consume.noise@gmail.com>
2013-08-15xinput: Cleanup implementation of XI up to v1.4Daniel Martin1-679/+719
- Structural changes: * indent with spaces only (replaced tabs) * indent attributes * move structures in front of the first request using it (Otherwise c_client.py would generate uncompileable code if we fix the uninterpreted lists.) * add version-controlled section comments (types, requests, events, errors) and move structures into their corresponding section * sort events and eventcopys by number - Additions: * add various missing enums and structs (i.e. DeviceChange, DeviceControl, DeviceName, ...) * uncomment commented out requests * linked in various enums into fields (via enum or altenum) - Other changes: * link to the txt specification in the git repo * fixed comments for "uninterpreted lists" - API CHANGES: * Request: GetDeviceMotionEvents The reply contains a list of events (of coordinates). So, we rename num_coords to num_events. The field is called nevents_return in the specification. The list was commented out anyways, so the rename shouldn't affect that much. * Request: SendExtensionEvent The list 'events' is a mask, make it a CARD8 like every other mask. * Events: FocusIn/Out Those ones haven't been named properly. They are called DeviceFocusIn/Out in the specification. In XI2 the names FocusIn/Out are used to introduce new events and cause name clashes. So, we have to rename the existing FocusIn/Out and give them their proper names. * Structures: *Feedback{Ctl,State} Rename the field id to feedback_id, as it's called in the spec. The only lists using those structs are commented out yet. So, this might not be called an api break. Signed-off-by: Daniel Martin <consume.noise@gmail.com>
2013-07-12Add support for X Generic Extension eventsDaniel Martin3-6/+29
With these patches, we are able to mark an XGE event as such and generate the correct header for it. XGE events can be found in the X Input Extension v2++. Signed-off-by: Daniel Martin <consume.noise@gmail.com> Reviewed-by: Keith Packard <keithp@keithp.com> Signed-off-by: Peter Harris <pharris@opentext.com>
2013-07-03sync: Change value list param of CreateAlarm and ChangeAlarm into switchLouis-Francis Ratté-Boulianne1-6/+56
Values for "Value" and "Delta" fields are 64-bit that couldn't be passed through a regular value list/mask. Signed-off-by: Louis-Francis Ratté-Boulianne <lfrb@collabora.com> Signed-off-by: Peter Harris <pharris@opentext.com>
2013-06-06res: Add ClientIdMask enumDaniel Martin1-1/+6
And make use of it in ClientIdSpec. v2: use <bit/> instead of <value/> in the enum Signed-off-by: Daniel Martin <consume.noise@gmail.com> Signed-off-by: Peter Harris <pharris@opentext.com>
2013-06-06res: Fix and rename list in ClientIdValueDaniel Martin1-1/+1
The list is a CARD32 and rename the field to "value" to match the specification. Signed-off-by: Daniel Martin <consume.noise@gmail.com> Signed-off-by: Peter Harris <pharris@opentext.com>
2013-06-06randr: Add provider object support (RandR v1.4)Daniel Martin1-15/+216
With RandR 1.4 provider objects have been introduced. "A provider object represents a GPU or virtual device providing services to the X server." To handle provider objects the following requests have been added: - GetProviders - GetProviderInfo - SetProviderOffloadSink - SetProviderOutputSource - ListProviderProperties - QueryProviderProperty - ConfigureProviderProperty - ChangeProviderProperty - DeleteProviderProperty - GetProviderProperty And the Notify event got 3 new subcodes: - ProviderChange - ProviderProperty - ResourceChange v2: - add missing name field to GetProviderInfo v3: - changed ProviderCapability enum o replaced <value> with <bit> o removed None - replaced "alignment pad list" with commented out <pad align="4"/> to be prepared for future enhancements - add brief description to commit msg about additions Signed-off-by: Daniel Martin <consume.noise@gmail.com> Signed-off-by: Peter Harris <pharris@opentext.com>
2013-06-06xtest: Version bump 2.1..2.2Daniel Martin1-2/+1
The implemented and upstream version is 2.2. Signed-off-by: Daniel Martin <consume.noise@gmail.com> Signed-off-by: Peter Harris <pharris@opentext.com>
2013-06-06glx: Version bump 1.3..1.4Daniel Martin1-2/+13
Add the BufferSwapComplete (v2) event. Signed-off-by: Daniel Martin <consume.noise@gmail.com> Signed-off-by: Peter Harris <pharris@opentext.com>
2013-06-06composite: Version bump 0.3..0.4Daniel Martin1-1/+1
The only difference between version 0.3 and 0.4 is that the clipping semantics have been redefined. That's just an internal change, no structure has to be modified. Signed-off-by: Daniel Martin <consume.noise@gmail.com> Signed-off-by: Peter Harris <pharris@opentext.com>
2013-06-06xfixes: Rename enum DirectionMask to BarrierDirec.Daniel Martin1-2/+2
Rename the enum 'DirectionMask' to 'BarrierDirections' to match the specification. Signed-off-by: Daniel Martin <consume.noise@gmail.com> Signed-off-by: Peter Harris <pharris@opentext.com>
2013-05-30XKB: Correct enum to maskMark Witmer1-18/+18
Changes fields with enums EventType, MapPart, or BoolCtrl to use them as masks instead.
2013-05-27screensaver: Use enum and mask attributesDaniel Martin1-5/+5
Signed-off-by: Daniel Martin <consume.noise@gmail.com> Signed-off-by: Peter Harris <pharris@opentext.com>
2013-05-27screensaver: Remove wrong fields from Notify eventDaniel Martin1-3/+0
This fixes bug #63158: screensaver notify event specification is incorrect https://bugs.freedesktop.org/show_bug.cgi?id=63158 As stated in the bug report the response_type and sequence field will be added automatically while parsing the specification. Additionally, the pad field is wrong. Signed-off-by: Daniel Martin <consume.noise@gmail.com> Signed-off-by: Peter Harris <pharris@opentext.com>
2013-05-23Prototype for XRes v1.2Erkki Seppälä1-1/+69
2013-05-23xcbgen: Handle multiple <enumref> in a <bitcase>Daniel Martin1-4/+11
Adopt the XML schema change from commit ee71d96 Allow multiple <enumref> in a <bitcase> and its usage with commit b3b5e02 XKB: Fix GetKbdByName. Signed-off-by: Daniel Martin <consume.noise@gmail.com> Signed-off-by: Peter Harris <pharris@opentext.com>
2013-04-16XKB: Fix calculation in GetIndicatorMapPeter Harris1-1/+1
Contrary to the spec, the server doesn't set nIndicators. Signed-off-by: Peter Harris <pharris@opentext.com>
2013-04-16XKB: Fix GetKbdByNamePeter Harris1-271/+23
Each part of the reply has a fake type, sequence, and length. In addition, some parts of the reply are encoded only once even when multiple bits are set. Signed-off-by: Peter Harris <pharris@opentext.com>
2013-04-16Allow multiple <enumref> in a <bitcase>Peter Harris2-5/+10
Signed-off-by: Peter Harris <pharris@opentext.com>
2013-04-16XKB: Change CARD8 to char where ASCII is expectedPeter Harris1-4/+4
This does not impact libxcb, but it makes some pretty-printers prettier. Signed-off-by: Peter Harris <pharris@opentext.com>
2013-04-16XKB: Fix VirtualModsPeter Harris1-3/+3
nVModMapKeys is usually larger than <popcount>virtualMods</popcount>. Signed-off-by: Peter Harris <pharris@opentext.com>
2013-04-16XKB: Fix SymInterpretPeter Harris1-16/+24
SymInterpret is referenced by the spec, but never defined. Therefore, the definition of SymInterpret is inferred from the server implementation. Signed-off-by: Peter Harris <pharris@opentext.com>
2013-04-16XKB: Fix CountedString16 paddingPeter Harris1-1/+17
Should be <pad align=4>, not <pad bytes=1>. This is a very long-winded way to write <pad align>, since libxcb doesn't support <pad align> yet. Signed-off-by: Peter Harris <pharris@opentext.com>
2013-04-16XKB: Remove CountedString8Peter Harris1-7/+0
CountedString8 is never used. Signed-off-by: Peter Harris <pharris@opentext.com>
2013-02-14xkb: Revert half of d42d791 XKB: Fix broken eventsDaniel Martin1-24/+12
The no-sequence-number attribute was not necessary to achive what commit d42d791 did. The first field automatically goes between the response_type and the sequence field in the header. So, adding the xkbType field would've been sufficient to fix the broken events. Reference-to: d42d791 XKB: Fix broken events
2013-02-14Simplify boolean attribute retrievalDaniel Martin1-2/+1
2013-02-14xfixes: Update to version 5Neil Roberts1-1/+29
This adds the two new functions in XFixes version 5 for handling pointer barriers. Signed-off-by: Neil Roberts <neil@linux.intel.com> Tested-by: Daniel Martin <consume.noise@gmail.com> Signed-off-by: Peter Harris <pharris@opentext.com>
2013-01-16autogen.sh: Implement GNOME Build APIColin Walters1-1/+3
http://people.gnome.org/~walters/docs/build-api.txt Signed-off-by: Adam Jackson <ajax@redhat.com>
2012-10-05Release xcb-proto 1.81.8Uli Schlachter2-1/+7
Signed-off-by: Uli Schlachter <psychon@znc.in>
2012-06-21XKB: Fix broken eventsDaniel Stone1-12/+36
XKB events all have exactly the same event number - 0 (from the XKB event base). Within this, they're all multiplexed by the xkbType field, which comes immediately after the event type field, before the sequence number. Without this field, the events are pretty much useless, so add it manually. Signed-off-by: Daniel Stone <daniel@fooishbar.org> Reviewed-by: Uli Schlachter <psychon@znc.in> Signed-off-by: Julien Danjou <julien@danjou.info>
2012-06-05dri2: Update to DRI2 1.4Chad Versace1-1/+13
In DRI2 1.4, the DRI2GetParam request was added. Signed-off-by: Chad Versace <chad.versace@linux.intel.com> Signed-off-by: Julien Danjou <julien@danjou.info>
2012-03-26xproto: add doc tags, xcbgen: handle doc tagsMichael Stapelberg5-20/+2950
Signed-off-by: Julien Danjou <julien@danjou.info>
2012-03-23Release xcb-proto 1.7.11.7.1Julien Danjou2-1/+7
Signed-off-by: Julien Danjou <julien@danjou.info>
2012-03-23Rename the ExprType "parent" attribute to "parents".Alex Plotnick1-2/+2
This is fallout from commit 76ca2c0b1527541be59c344118c538ba055ad9d8, which renamed the *parent parameter of ExprType.__init__, but failed to rename the instance attribute to which it was assigned. Signed-off-by: Julien Danjou <julien@danjou.info>
2012-02-10Add autogen.sh to EXTRA_DIST.Arnaud Fontaine1-1/+1
Reviewed-by: Uli Schlachter <psychon@znc.in>
2012-01-26Remove now unnecessary files as everything is implemented in xcbgen.Arnaud Fontaine3-216/+0
Reviewed-by: Jamey Sharp <jamey@minilop.net>
2012-01-23Add ge and xf86vidmode protocol descriptions.Arnaud Fontaine1-0/+2
Reviewed-by: Jamey Sharp <jamey@minilop.net>
2012-01-11Release xcb-proto 1.71.7Julien Danjou2-2/+34
2012-01-11Fix XKB GetState missing lookupMods fieldRobert Ancell1-0/+1
This fixes #43606 Signed-off-by: Julien Danjou <julien@danjou.info>
2012-01-11Fix some fields nameRobert Ancell1-3/+3
XKB-SetControls has some incorrectly named fields according to the spec, interanlRealMods -> internalRealMods, Internal where Ignore should be used. This fixes #43605 Signed-off-by: Julien Danjou <julien@danjou.info>
2012-01-11Fix 9efd2ac87b9eca51d07173cf33d48f4d3b77509e field nameJulien Danjou1-2/+2
Signed-off-by: Julien Danjou <julien@danjou.info>
2012-01-11Fix SetFontPath path string encodingRobert Ancell1-1/+4
SetFontPath doesn't encode the path strings correctly - it should be the same as the GetFontPath reply. Fixes #43602 Signed-off-by: Julien Danjou <julien@danjou.info>
2012-01-11Fix ChangeHosts address stringRobert Ancell1-1/+1
ChangeHosts incorrectly encodes address as a string, not a binary blob. It should be the same as in the HOSTS structure. Fixes #43604 Signed-off-by: Julien Danjou <julien@danjou.info>
2011-12-08dri2: Update to version 1.3 (v2)Fredrik Höglund1-1/+99
Signed-off-by: Fredrik Höglund <fredrik@kde.org> Signed-off-by: Peter Harris <pharris@opentext.com>
2011-12-06glx: Add protocol for GLX_ARB_create_context and GLX_ARB_create_context_profileIan Romanick1-0/+59
Signed-off-by: Ian Romanick <ian.d.romanick@intel.com> Signed-off-by: Peter Harris <pharris@opentext.com>
2011-12-06glx: Use FBCONFIG type for fbconfig parameter of CreateNewContext and ↵Ian Romanick1-2/+2
CreatePixmap Signed-off-by: Ian Romanick <ian.d.romanick@intel.com> Signed-off-by: Peter Harris <pharris@opentext.com>
2011-12-06glx: Use glx:CONTEXT for share_list parameter of CreateNewContextIan Romanick1-1/+1
This matches the share_list parameter of CreateContext. Signed-off-by: Ian Romanick <ian.d.romanick@intel.com> Signed-off-by: Peter Harris <pharris@opentext.com>
2011-12-06glx: Replace some 'reserved' fields with explicit paddingIan Romanick1-2/+1
In the GLX protocol specs, the various fields named 'reserved' are just there to provide alignment padding. Signed-off-by: Ian Romanick <ian.d.romanick@intel.com> Reviewed-by: Peter Harris <pharris@opentext.com> Signed-off-by: Peter Harris <pharris@opentext.com>
2011-11-10add libdir/exec_prefix to xcb-xproto.pcMike Frysinger1-0/+2
If we want to base other paths off of exec_prefix or libdir (like the python path), we can't because the xcb-proto.pc.in file omits those variables. Add them so people can leverage them in their own builds. Signed-off-by: Mike Frysinger <vapier@gentoo.org> Signed-off-by: Julien Danjou <julien@danjou.info>
2011-10-13Corrected type of FakeInput rootX & rootY fieldsAlex Plotnick1-2/+2
The FakeInput request defined by the XTEST extension has two fields, rootX and rootY, that are used to indicate relative or absolute pointer coordinates for fake motion events. These fields are of type INT16, not CARD16. (They must be signed to allow for negative relative motions and to align with the root-x and root-y fields of MotionNotify events.) Signed-off-by: Peter Harris <pharris@opentext.com>