summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLauri Kasanen <cand@gmx.com>2013-12-19 21:43:25 +0200
committerMatt Turner <mattst88@gmail.com>2013-12-20 17:00:57 -0800
commitfcefdc9a595c52ade2be15e0f3a2f301fee3599c (patch)
tree199c8e9cd69b7dd3b389a1839ad4668d78fc5f48 /configure.ac
parent79f268978d2341205f03738a2bc981838c09d920 (diff)
mesa: Fix build to properly check for supported compiler flags
Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=72708 Reviewed-by: Matt Turner <mattst88@gmail.com> Signed-off-by: Lauri Kasanen <cand@gmx.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 07680c09a1..f75325d33d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -231,6 +231,12 @@ AC_SUBST([VISIBILITY_CFLAGS])
AC_SUBST([VISIBILITY_CXXFLAGS])
dnl
+dnl Optional flags, check for compiler support
+dnl
+AX_CHECK_COMPILE_FLAG([-msse4.1], [SSE41_SUPPORTED=1], [SSE41_SUPPORTED=0])
+AM_CONDITIONAL([SSE41_SUPPORTED], [test x$SSE41_SUPPORTED = x1])
+
+dnl
dnl Hacks to enable 32 or 64 bit build
dnl
AC_ARG_ENABLE([32-bit],