summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2013-09-24 10:24:07 -0700
committerEric Anholt <eric@anholt.net>2013-10-24 14:13:08 -0700
commitead86e378fd4a8b19f7a3f185c751a41b2530b2f (patch)
tree2379a451f6bc5b72cc3c5cd0dc9a8afd141518f9 /configure.ac
parent1925a9aebd64b2e08574118891394d9d56db25ae (diff)
nouveau: Build the driver into the shared mesa_dri_drivers.so.
v2: drop dridir now that it's unused. v3: Consistently put spaces around += in the updated Makefile.am block. v4: Set a global driverAPI variable so loaders don't have to update to createNewScreen2() (though they may want to for thread safety). v5: Fix missed public symbol in nouveau. (caught by Emil) Reviewed-by: Matt Turner <mattst88@gmail.com> (v2) Reviewed-by: Emil Velikov <emil.l.velikov@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d47636d4da..c352cf5a53 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1039,7 +1039,7 @@ fi
enable_dricore=no
enable_megadriver=no
for driver in $DRI_DIRS; do
- if test $driver != "i965"; then
+ if test $driver != "i965" -a $driver != "nouveau"; then
enable_dricore=yes
else
enable_megadriver=yes