summaryrefslogtreecommitdiff
path: root/configure
diff options
context:
space:
mode:
authorMichael Biebl <biebl@debian.org>2011-10-28 23:51:31 +0200
committerMichael Biebl <biebl@debian.org>2011-10-28 23:51:31 +0200
commit0c599d38ef93a3b200056dbd936f7ebbe8ed7381 (patch)
treeac328c108de854fc2db06228cdc29482dcda1b94 /configure
parent5cf5e51ac694b1bdd7551a30035a7a9451a7167d (diff)
Imported Upstream version 0.9.1.95
Diffstat (limited to 'configure')
-rwxr-xr-xconfigure502
1 files changed, 315 insertions, 187 deletions
diff --git a/configure b/configure
index 0a34c8ba..ecb649ed 100755
--- a/configure
+++ b/configure
@@ -1,6 +1,6 @@
#! /bin/sh
# Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.68 for nm-applet 0.9.0.
+# Generated by GNU Autoconf 2.68 for nm-applet 0.9.1.95.
#
# Report bugs to <https://bugzilla.gnome.org/enter_bug.cgi?product=NetworkManager>.
#
@@ -571,8 +571,8 @@ MAKEFLAGS=
# Identity of this package.
PACKAGE_NAME='nm-applet'
PACKAGE_TARNAME='network-manager-applet'
-PACKAGE_VERSION='0.9.0'
-PACKAGE_STRING='nm-applet 0.9.0'
+PACKAGE_VERSION='0.9.1.95'
+PACKAGE_STRING='nm-applet 0.9.1.95'
PACKAGE_BUGREPORT='https://bugzilla.gnome.org/enter_bug.cgi?product=NetworkManager'
PACKAGE_URL=''
@@ -647,9 +647,8 @@ NMA_LIBS
NMA_CFLAGS
GOBJECT_LIBS
GOBJECT_CFLAGS
-PKG_CONFIG_LIBDIR
-PKG_CONFIG_PATH
-PKG_CONFIG
+ISO_CODES_LIBS
+ISO_CODES_CFLAGS
MKINSTALLDIRS
POSUB
POFILES
@@ -723,6 +722,9 @@ LIBTOOL
EGREP
GREP
CPP
+PKG_CONFIG_LIBDIR
+PKG_CONFIG_PATH
+PKG_CONFIG
am__fastdepCC_FALSE
am__fastdepCC_TRUE
CCDEPMODE
@@ -819,6 +821,7 @@ with_gnu_ld
with_sysroot
enable_libtool_lock
enable_nls
+enable_iso_codes
with_gtkver
with_dbus_sys
with_bluetooth
@@ -835,10 +838,12 @@ CFLAGS
LDFLAGS
LIBS
CPPFLAGS
-CPP
PKG_CONFIG
PKG_CONFIG_PATH
PKG_CONFIG_LIBDIR
+CPP
+ISO_CODES_CFLAGS
+ISO_CODES_LIBS
GOBJECT_CFLAGS
GOBJECT_LIBS
NMA_CFLAGS
@@ -1401,7 +1406,7 @@ if test "$ac_init_help" = "long"; then
# Omit some internal or obsolete options to make the list less imposing.
# This message is too long to be a string in the A/UX 3.1 sh.
cat <<_ACEOF
-\`configure' configures nm-applet 0.9.0 to adapt to many kinds of systems.
+\`configure' configures nm-applet 0.9.1.95 to adapt to many kinds of systems.
Usage: $0 [OPTION]... [VAR=VALUE]...
@@ -1472,7 +1477,7 @@ fi
if test -n "$ac_init_help"; then
case $ac_init_help in
- short | recursive ) echo "Configuration of nm-applet 0.9.0:";;
+ short | recursive ) echo "Configuration of nm-applet 0.9.1.95:";;
esac
cat <<\_ACEOF
@@ -1492,6 +1497,7 @@ Optional Features:
optimize for fast installation [default=yes]
--disable-libtool-lock avoid locking (might break parallel builds)
--disable-nls do not use Native Language Support
+ --disable-iso-codes do not check for iso-codes at build-time
--disable-schemas-install
Disable the schemas installation
--enable-more-warnings Maximum compiler warnings
@@ -1521,12 +1527,16 @@ Some influential environment variables:
LIBS libraries to pass to the linker, e.g. -l<library>
CPPFLAGS (Objective) C/C++ preprocessor flags, e.g. -I<include dir> if
you have headers in a nonstandard directory <include dir>
- CPP C preprocessor
PKG_CONFIG path to pkg-config utility
PKG_CONFIG_PATH
directories to add to pkg-config's search path
PKG_CONFIG_LIBDIR
path overriding pkg-config's built-in search path
+ CPP C preprocessor
+ ISO_CODES_CFLAGS
+ C compiler flags for ISO_CODES, overriding pkg-config
+ ISO_CODES_LIBS
+ linker flags for ISO_CODES, overriding pkg-config
GOBJECT_CFLAGS
C compiler flags for GOBJECT, overriding pkg-config
GOBJECT_LIBS
@@ -1627,7 +1637,7 @@ fi
test -n "$ac_init_help" && exit $ac_status
if $ac_init_version; then
cat <<\_ACEOF
-nm-applet configure 0.9.0
+nm-applet configure 0.9.1.95
generated by GNU Autoconf 2.68
Copyright (C) 2010 Free Software Foundation, Inc.
@@ -2050,7 +2060,7 @@ cat >config.log <<_ACEOF
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.
-It was created by nm-applet $as_me 0.9.0, which was
+It was created by nm-applet $as_me 0.9.1.95, which was
generated by GNU Autoconf 2.68. Invocation command line was
$ $0 $@
@@ -2870,7 +2880,7 @@ fi
# Define the identity of the package.
PACKAGE='network-manager-applet'
- VERSION='0.9.0'
+ VERSION='0.9.1.95'
cat >>confdefs.h <<_ACEOF
@@ -4058,6 +4068,125 @@ fi
+
+
+
+
+if test "x$ac_cv_env_PKG_CONFIG_set" != "xset"; then
+ if test -n "$ac_tool_prefix"; then
+ # Extract the first word of "${ac_tool_prefix}pkg-config", so it can be a program name with args.
+set dummy ${ac_tool_prefix}pkg-config; ac_word=$2
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
+$as_echo_n "checking for $ac_word... " >&6; }
+if ${ac_cv_path_PKG_CONFIG+:} false; then :
+ $as_echo_n "(cached) " >&6
+else
+ case $PKG_CONFIG in
+ [\\/]* | ?:[\\/]*)
+ ac_cv_path_PKG_CONFIG="$PKG_CONFIG" # Let the user override the test with a path.
+ ;;
+ *)
+ as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+for as_dir in $PATH
+do
+ IFS=$as_save_IFS
+ test -z "$as_dir" && as_dir=.
+ for ac_exec_ext in '' $ac_executable_extensions; do
+ if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
+ ac_cv_path_PKG_CONFIG="$as_dir/$ac_word$ac_exec_ext"
+ $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
+ break 2
+ fi
+done
+ done
+IFS=$as_save_IFS
+
+ ;;
+esac
+fi
+PKG_CONFIG=$ac_cv_path_PKG_CONFIG
+if test -n "$PKG_CONFIG"; then
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $PKG_CONFIG" >&5
+$as_echo "$PKG_CONFIG" >&6; }
+else
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+$as_echo "no" >&6; }
+fi
+
+
+fi
+if test -z "$ac_cv_path_PKG_CONFIG"; then
+ ac_pt_PKG_CONFIG=$PKG_CONFIG
+ # Extract the first word of "pkg-config", so it can be a program name with args.
+set dummy pkg-config; ac_word=$2
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
+$as_echo_n "checking for $ac_word... " >&6; }
+if ${ac_cv_path_ac_pt_PKG_CONFIG+:} false; then :
+ $as_echo_n "(cached) " >&6
+else
+ case $ac_pt_PKG_CONFIG in
+ [\\/]* | ?:[\\/]*)
+ ac_cv_path_ac_pt_PKG_CONFIG="$ac_pt_PKG_CONFIG" # Let the user override the test with a path.
+ ;;
+ *)
+ as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+for as_dir in $PATH
+do
+ IFS=$as_save_IFS
+ test -z "$as_dir" && as_dir=.
+ for ac_exec_ext in '' $ac_executable_extensions; do
+ if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
+ ac_cv_path_ac_pt_PKG_CONFIG="$as_dir/$ac_word$ac_exec_ext"
+ $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
+ break 2
+ fi
+done
+ done
+IFS=$as_save_IFS
+
+ ;;
+esac
+fi
+ac_pt_PKG_CONFIG=$ac_cv_path_ac_pt_PKG_CONFIG
+if test -n "$ac_pt_PKG_CONFIG"; then
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_pt_PKG_CONFIG" >&5
+$as_echo "$ac_pt_PKG_CONFIG" >&6; }
+else
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+$as_echo "no" >&6; }
+fi
+
+ if test "x$ac_pt_PKG_CONFIG" = x; then
+ PKG_CONFIG=""
+ else
+ case $cross_compiling:$ac_tool_warned in
+yes:)
+{ $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: using cross tools not prefixed with host triplet" >&5
+$as_echo "$as_me: WARNING: using cross tools not prefixed with host triplet" >&2;}
+ac_tool_warned=yes ;;
+esac
+ PKG_CONFIG=$ac_pt_PKG_CONFIG
+ fi
+else
+ PKG_CONFIG="$ac_cv_path_PKG_CONFIG"
+fi
+
+fi
+if test -n "$PKG_CONFIG"; then
+ _pkg_min_version=0.9.0
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking pkg-config is at least version $_pkg_min_version" >&5
+$as_echo_n "checking pkg-config is at least version $_pkg_min_version... " >&6; }
+ if $PKG_CONFIG --atleast-pkgconfig-version $_pkg_min_version; then
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
+$as_echo "yes" >&6; }
+ else
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+$as_echo "no" >&6; }
+ PKG_CONFIG=""
+ fi
+fi
+
+
ac_ext=c
ac_cpp='$CPP $CPPFLAGS'
ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
@@ -13114,6 +13243,122 @@ $as_echo "$LINGUAS" >&6; }
< $srcdir/po/POTFILES.in > po/POTFILES
+# Check for iso-codes for country names translation
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether to disable iso-codes at build-time" >&5
+$as_echo_n "checking whether to disable iso-codes at build-time... " >&6; }
+# Check whether --enable-iso-codes was given.
+if test "${enable_iso_codes+set}" = set; then :
+ enableval=$enable_iso_codes;
+else
+ disable_iso_codes_check=no
+fi
+
+if test x$disable_iso_codes_check = xno ; then
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+$as_echo "no" >&6; }
+else
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
+$as_echo "yes" >&6; }
+fi
+
+if test x$disable_iso_codes_check = "xno" ; then
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether iso-codes has iso_3166 domain" >&5
+$as_echo_n "checking whether iso-codes has iso_3166 domain... " >&6; }
+ if $PKG_CONFIG --variable=domains iso-codes | grep iso_3166 >/dev/null ; then
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
+$as_echo "yes" >&6; }
+ else
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+$as_echo "no" >&6; }
+ fi
+
+cat >>confdefs.h <<_ACEOF
+#define ISO_CODES_PREFIX "`$PKG_CONFIG --variable=prefix iso-codes`"
+_ACEOF
+
+
+pkg_failed=no
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for ISO_CODES" >&5
+$as_echo_n "checking for ISO_CODES... " >&6; }
+
+if test -n "$ISO_CODES_CFLAGS"; then
+ pkg_cv_ISO_CODES_CFLAGS="$ISO_CODES_CFLAGS"
+ elif test -n "$PKG_CONFIG"; then
+ if test -n "$PKG_CONFIG" && \
+ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"iso-codes\""; } >&5
+ ($PKG_CONFIG --exists --print-errors "iso-codes") 2>&5
+ ac_status=$?
+ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
+ test $ac_status = 0; }; then
+ pkg_cv_ISO_CODES_CFLAGS=`$PKG_CONFIG --cflags "iso-codes" 2>/dev/null`
+else
+ pkg_failed=yes
+fi
+ else
+ pkg_failed=untried
+fi
+if test -n "$ISO_CODES_LIBS"; then
+ pkg_cv_ISO_CODES_LIBS="$ISO_CODES_LIBS"
+ elif test -n "$PKG_CONFIG"; then
+ if test -n "$PKG_CONFIG" && \
+ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"iso-codes\""; } >&5
+ ($PKG_CONFIG --exists --print-errors "iso-codes") 2>&5
+ ac_status=$?
+ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
+ test $ac_status = 0; }; then
+ pkg_cv_ISO_CODES_LIBS=`$PKG_CONFIG --libs "iso-codes" 2>/dev/null`
+else
+ pkg_failed=yes
+fi
+ else
+ pkg_failed=untried
+fi
+
+
+
+if test $pkg_failed = yes; then
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+$as_echo "no" >&6; }
+
+if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
+ _pkg_short_errors_supported=yes
+else
+ _pkg_short_errors_supported=no
+fi
+ if test $_pkg_short_errors_supported = yes; then
+ ISO_CODES_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors "iso-codes" 2>&1`
+ else
+ ISO_CODES_PKG_ERRORS=`$PKG_CONFIG --print-errors "iso-codes" 2>&1`
+ fi
+ # Put the nasty error message in config.log where it belongs
+ echo "$ISO_CODES_PKG_ERRORS" >&5
+
+ echo -e "\n$ISO_CODES_PKG_ERRORS.\n"
+ echo "Consider installing the package or adjusting the PKG_CONFIG_PATH environment variable."
+ echo "You can also disable build-time check for 'iso-codes' via --disable-iso-codes";
+ exit 1;
+elif test $pkg_failed = untried; then
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+$as_echo "no" >&6; }
+ echo -e "\n$ISO_CODES_PKG_ERRORS.\n"
+ echo "Consider installing the package or adjusting the PKG_CONFIG_PATH environment variable."
+ echo "You can also disable build-time check for 'iso-codes' via --disable-iso-codes";
+ exit 1;
+else
+ ISO_CODES_CFLAGS=$pkg_cv_ISO_CODES_CFLAGS
+ ISO_CODES_LIBS=$pkg_cv_ISO_CODES_LIBS
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
+$as_echo "yes" >&6; }
+
+fi
+else
+
+cat >>confdefs.h <<_ACEOF
+#define ISO_CODES_PREFIX "$prefix"
+_ACEOF
+
+fi
+
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether byte ordering is bigendian" >&5
$as_echo_n "checking whether byte ordering is bigendian... " >&6; }
if ${ac_cv_c_bigendian+:} false; then :
@@ -13340,125 +13585,6 @@ $as_echo "#define AC_APPLE_UNIVERSAL_BUILD 1" >>confdefs.h
-
-
-
-
-
-if test "x$ac_cv_env_PKG_CONFIG_set" != "xset"; then
- if test -n "$ac_tool_prefix"; then
- # Extract the first word of "${ac_tool_prefix}pkg-config", so it can be a program name with args.
-set dummy ${ac_tool_prefix}pkg-config; ac_word=$2
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
-$as_echo_n "checking for $ac_word... " >&6; }
-if ${ac_cv_path_PKG_CONFIG+:} false; then :
- $as_echo_n "(cached) " >&6
-else
- case $PKG_CONFIG in
- [\\/]* | ?:[\\/]*)
- ac_cv_path_PKG_CONFIG="$PKG_CONFIG" # Let the user override the test with a path.
- ;;
- *)
- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
-for as_dir in $PATH
-do
- IFS=$as_save_IFS
- test -z "$as_dir" && as_dir=.
- for ac_exec_ext in '' $ac_executable_extensions; do
- if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
- ac_cv_path_PKG_CONFIG="$as_dir/$ac_word$ac_exec_ext"
- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
- break 2
- fi
-done
- done
-IFS=$as_save_IFS
-
- ;;
-esac
-fi
-PKG_CONFIG=$ac_cv_path_PKG_CONFIG
-if test -n "$PKG_CONFIG"; then
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $PKG_CONFIG" >&5
-$as_echo "$PKG_CONFIG" >&6; }
-else
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
-$as_echo "no" >&6; }
-fi
-
-
-fi
-if test -z "$ac_cv_path_PKG_CONFIG"; then
- ac_pt_PKG_CONFIG=$PKG_CONFIG
- # Extract the first word of "pkg-config", so it can be a program name with args.
-set dummy pkg-config; ac_word=$2
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
-$as_echo_n "checking for $ac_word... " >&6; }
-if ${ac_cv_path_ac_pt_PKG_CONFIG+:} false; then :
- $as_echo_n "(cached) " >&6
-else
- case $ac_pt_PKG_CONFIG in
- [\\/]* | ?:[\\/]*)
- ac_cv_path_ac_pt_PKG_CONFIG="$ac_pt_PKG_CONFIG" # Let the user override the test with a path.
- ;;
- *)
- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
-for as_dir in $PATH
-do
- IFS=$as_save_IFS
- test -z "$as_dir" && as_dir=.
- for ac_exec_ext in '' $ac_executable_extensions; do
- if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
- ac_cv_path_ac_pt_PKG_CONFIG="$as_dir/$ac_word$ac_exec_ext"
- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
- break 2
- fi
-done
- done
-IFS=$as_save_IFS
-
- ;;
-esac
-fi
-ac_pt_PKG_CONFIG=$ac_cv_path_ac_pt_PKG_CONFIG
-if test -n "$ac_pt_PKG_CONFIG"; then
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_pt_PKG_CONFIG" >&5
-$as_echo "$ac_pt_PKG_CONFIG" >&6; }
-else
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
-$as_echo "no" >&6; }
-fi
-
- if test "x$ac_pt_PKG_CONFIG" = x; then
- PKG_CONFIG=""
- else
- case $cross_compiling:$ac_tool_warned in
-yes:)
-{ $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: using cross tools not prefixed with host triplet" >&5
-$as_echo "$as_me: WARNING: using cross tools not prefixed with host triplet" >&2;}
-ac_tool_warned=yes ;;
-esac
- PKG_CONFIG=$ac_pt_PKG_CONFIG
- fi
-else
- PKG_CONFIG="$ac_cv_path_PKG_CONFIG"
-fi
-
-fi
-if test -n "$PKG_CONFIG"; then
- _pkg_min_version=0.9.0
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking pkg-config is at least version $_pkg_min_version" >&5
-$as_echo_n "checking pkg-config is at least version $_pkg_min_version... " >&6; }
- if $PKG_CONFIG --atleast-pkgconfig-version $_pkg_min_version; then
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
-$as_echo "yes" >&6; }
- else
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
-$as_echo "no" >&6; }
- PKG_CONFIG=""
- fi
-fi
-
pkg_failed=no
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for GOBJECT" >&5
$as_echo_n "checking for GOBJECT... " >&6; }
@@ -13561,27 +13687,27 @@ if test -n "$NMA_CFLAGS"; then
if test -n "$PKG_CONFIG" && \
{ { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"dbus-glib-1 >= 0.74
glib-2.0 >= 2.16
- NetworkManager >= 0.9
- libnm-glib >= 0.9
- libnm-util >= 0.9
- libnm-glib-vpn >= 0.9
+ NetworkManager >= 0.9.1
+ libnm-glib >= 0.9.1
+ libnm-util >= 0.9.1
+ libnm-glib-vpn >= 0.9.1
gmodule-export-2.0\""; } >&5
($PKG_CONFIG --exists --print-errors "dbus-glib-1 >= 0.74
glib-2.0 >= 2.16
- NetworkManager >= 0.9
- libnm-glib >= 0.9
- libnm-util >= 0.9
- libnm-glib-vpn >= 0.9
+ NetworkManager >= 0.9.1
+ libnm-glib >= 0.9.1
+ libnm-util >= 0.9.1
+ libnm-glib-vpn >= 0.9.1
gmodule-export-2.0") 2>&5
ac_status=$?
$as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
test $ac_status = 0; }; then
pkg_cv_NMA_CFLAGS=`$PKG_CONFIG --cflags "dbus-glib-1 >= 0.74
glib-2.0 >= 2.16
- NetworkManager >= 0.9
- libnm-glib >= 0.9
- libnm-util >= 0.9
- libnm-glib-vpn >= 0.9
+ NetworkManager >= 0.9.1
+ libnm-glib >= 0.9.1
+ libnm-util >= 0.9.1
+ libnm-glib-vpn >= 0.9.1
gmodule-export-2.0" 2>/dev/null`
else
pkg_failed=yes
@@ -13595,27 +13721,27 @@ if test -n "$NMA_LIBS"; then
if test -n "$PKG_CONFIG" && \
{ { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"dbus-glib-1 >= 0.74
glib-2.0 >= 2.16
- NetworkManager >= 0.9
- libnm-glib >= 0.9
- libnm-util >= 0.9
- libnm-glib-vpn >= 0.9
+ NetworkManager >= 0.9.1
+ libnm-glib >= 0.9.1
+ libnm-util >= 0.9.1
+ libnm-glib-vpn >= 0.9.1
gmodule-export-2.0\""; } >&5
($PKG_CONFIG --exists --print-errors "dbus-glib-1 >= 0.74
glib-2.0 >= 2.16
- NetworkManager >= 0.9
- libnm-glib >= 0.9
- libnm-util >= 0.9
- libnm-glib-vpn >= 0.9
+ NetworkManager >= 0.9.1
+ libnm-glib >= 0.9.1
+ libnm-util >= 0.9.1
+ libnm-glib-vpn >= 0.9.1
gmodule-export-2.0") 2>&5
ac_status=$?
$as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
test $ac_status = 0; }; then
pkg_cv_NMA_LIBS=`$PKG_CONFIG --libs "dbus-glib-1 >= 0.74
glib-2.0 >= 2.16
- NetworkManager >= 0.9
- libnm-glib >= 0.9
- libnm-util >= 0.9
- libnm-glib-vpn >= 0.9
+ NetworkManager >= 0.9.1
+ libnm-glib >= 0.9.1
+ libnm-util >= 0.9.1
+ libnm-glib-vpn >= 0.9.1
gmodule-export-2.0" 2>/dev/null`
else
pkg_failed=yes
@@ -13638,18 +13764,18 @@ fi
if test $_pkg_short_errors_supported = yes; then
NMA_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors "dbus-glib-1 >= 0.74
glib-2.0 >= 2.16
- NetworkManager >= 0.9
- libnm-glib >= 0.9
- libnm-util >= 0.9
- libnm-glib-vpn >= 0.9
+ NetworkManager >= 0.9.1
+ libnm-glib >= 0.9.1
+ libnm-util >= 0.9.1
+ libnm-glib-vpn >= 0.9.1
gmodule-export-2.0" 2>&1`
else
NMA_PKG_ERRORS=`$PKG_CONFIG --print-errors "dbus-glib-1 >= 0.74
glib-2.0 >= 2.16
- NetworkManager >= 0.9
- libnm-glib >= 0.9
- libnm-util >= 0.9
- libnm-glib-vpn >= 0.9
+ NetworkManager >= 0.9.1
+ libnm-glib >= 0.9.1
+ libnm-util >= 0.9.1
+ libnm-glib-vpn >= 0.9.1
gmodule-export-2.0" 2>&1`
fi
# Put the nasty error message in config.log where it belongs
@@ -13657,10 +13783,10 @@ fi
as_fn_error $? "Package requirements (dbus-glib-1 >= 0.74
glib-2.0 >= 2.16
- NetworkManager >= 0.9
- libnm-glib >= 0.9
- libnm-util >= 0.9
- libnm-glib-vpn >= 0.9
+ NetworkManager >= 0.9.1
+ libnm-glib >= 0.9.1
+ libnm-util >= 0.9.1
+ libnm-glib-vpn >= 0.9.1
gmodule-export-2.0) were not met:
$NMA_PKG_ERRORS
@@ -14716,17 +14842,17 @@ if test -n "$GNOME_BLUETOOTH_CFLAGS"; then
elif test -n "$PKG_CONFIG"; then
if test -n "$PKG_CONFIG" && \
{ { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"gnome-bluetooth-1.0 >= 2.27.6
- libnm-util >= 0.9
- libnm-glib >= 0.9\""; } >&5
+ libnm-util >= 0.9.1
+ libnm-glib >= 0.9.1\""; } >&5
($PKG_CONFIG --exists --print-errors "gnome-bluetooth-1.0 >= 2.27.6
- libnm-util >= 0.9
- libnm-glib >= 0.9") 2>&5
+ libnm-util >= 0.9.1
+ libnm-glib >= 0.9.1") 2>&5
ac_status=$?
$as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
test $ac_status = 0; }; then
pkg_cv_GNOME_BLUETOOTH_CFLAGS=`$PKG_CONFIG --cflags "gnome-bluetooth-1.0 >= 2.27.6
- libnm-util >= 0.9
- libnm-glib >= 0.9" 2>/dev/null`
+ libnm-util >= 0.9.1
+ libnm-glib >= 0.9.1" 2>/dev/null`
else
pkg_failed=yes
fi
@@ -14738,17 +14864,17 @@ if test -n "$GNOME_BLUETOOTH_LIBS"; then
elif test -n "$PKG_CONFIG"; then
if test -n "$PKG_CONFIG" && \
{ { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"gnome-bluetooth-1.0 >= 2.27.6
- libnm-util >= 0.9
- libnm-glib >= 0.9\""; } >&5
+ libnm-util >= 0.9.1
+ libnm-glib >= 0.9.1\""; } >&5
($PKG_CONFIG --exists --print-errors "gnome-bluetooth-1.0 >= 2.27.6
- libnm-util >= 0.9
- libnm-glib >= 0.9") 2>&5
+ libnm-util >= 0.9.1
+ libnm-glib >= 0.9.1") 2>&5
ac_status=$?
$as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
test $ac_status = 0; }; then
pkg_cv_GNOME_BLUETOOTH_LIBS=`$PKG_CONFIG --libs "gnome-bluetooth-1.0 >= 2.27.6
- libnm-util >= 0.9
- libnm-glib >= 0.9" 2>/dev/null`
+ libnm-util >= 0.9.1
+ libnm-glib >= 0.9.1" 2>/dev/null`
else
pkg_failed=yes
fi
@@ -14769,12 +14895,12 @@ else
fi
if test $_pkg_short_errors_supported = yes; then
GNOME_BLUETOOTH_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors "gnome-bluetooth-1.0 >= 2.27.6
- libnm-util >= 0.9
- libnm-glib >= 0.9" 2>&1`
+ libnm-util >= 0.9.1
+ libnm-glib >= 0.9.1" 2>&1`
else
GNOME_BLUETOOTH_PKG_ERRORS=`$PKG_CONFIG --print-errors "gnome-bluetooth-1.0 >= 2.27.6
- libnm-util >= 0.9
- libnm-glib >= 0.9" 2>&1`
+ libnm-util >= 0.9.1
+ libnm-glib >= 0.9.1" 2>&1`
fi
# Put the nasty error message in config.log where it belongs
echo "$GNOME_BLUETOOTH_PKG_ERRORS" >&5
@@ -15004,7 +15130,7 @@ fi
-ac_config_files="$ac_config_files Makefile src/Makefile src/marshallers/Makefile src/utils/Makefile src/utils/tests/Makefile src/gconf-helpers/Makefile src/gconf-helpers/tests/Makefile src/wireless-security/Makefile src/connection-editor/Makefile src/gnome-bluetooth/Makefile icons/Makefile icons/16/Makefile icons/22/Makefile icons/32/Makefile icons/48/Makefile icons/scalable/Makefile po/Makefile.in"
+ac_config_files="$ac_config_files Makefile src/Makefile src/libnm-gtk/Makefile src/libnm-gtk/libnm-gtk.pc src/marshallers/Makefile src/utils/Makefile src/utils/tests/Makefile src/gconf-helpers/Makefile src/gconf-helpers/tests/Makefile src/wireless-security/Makefile src/connection-editor/Makefile src/gnome-bluetooth/Makefile icons/Makefile icons/16/Makefile icons/22/Makefile icons/32/Makefile icons/48/Makefile icons/scalable/Makefile po/Makefile.in"
cat >confcache <<\_ACEOF
# This file is a shell script that caches the results of configure
@@ -15561,7 +15687,7 @@ cat >>$CONFIG_STATUS <<\_ACEOF || ac_write_fail=1
# report actual input values of CONFIG_FILES etc. instead of their
# values after options handling.
ac_log="
-This file was extended by nm-applet $as_me 0.9.0, which was
+This file was extended by nm-applet $as_me 0.9.1.95, which was
generated by GNU Autoconf 2.68. Invocation command line was
CONFIG_FILES = $CONFIG_FILES
@@ -15627,7 +15753,7 @@ _ACEOF
cat >>$CONFIG_STATUS <<_ACEOF || ac_write_fail=1
ac_cs_config="`$as_echo "$ac_configure_args" | sed 's/^ //; s/[\\""\`\$]/\\\\&/g'`"
ac_cs_version="\\
-nm-applet config.status 0.9.0
+nm-applet config.status 0.9.1.95
configured by $0, generated by GNU Autoconf 2.68,
with options \\"\$ac_cs_config\\"
@@ -16040,6 +16166,8 @@ do
"default-1") CONFIG_COMMANDS="$CONFIG_COMMANDS default-1" ;;
"Makefile") CONFIG_FILES="$CONFIG_FILES Makefile" ;;
"src/Makefile") CONFIG_FILES="$CONFIG_FILES src/Makefile" ;;
+ "src/libnm-gtk/Makefile") CONFIG_FILES="$CONFIG_FILES src/libnm-gtk/Makefile" ;;
+ "src/libnm-gtk/libnm-gtk.pc") CONFIG_FILES="$CONFIG_FILES src/libnm-gtk/libnm-gtk.pc" ;;
"src/marshallers/Makefile") CONFIG_FILES="$CONFIG_FILES src/marshallers/Makefile" ;;
"src/utils/Makefile") CONFIG_FILES="$CONFIG_FILES src/utils/Makefile" ;;
"src/utils/tests/Makefile") CONFIG_FILES="$CONFIG_FILES src/utils/tests/Makefile" ;;