summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Williams <dcbw@redhat.com>2016-02-22 14:34:26 -0600
committerDan Williams <dcbw@redhat.com>2016-03-18 09:51:28 -0500
commit56052d8b0f26afc699aabf6fd9c4822bb16ead03 (patch)
tree622635a92eb34b785ee36ca3abb6ab3bb19b8490 /configure.ac
parenta8a4804dd44007f08e874a61235cb20b1ccf94f4 (diff)
applet: don't use GtkImageMenuItems (bgo #740574)
GtkImageMenuItems are deprecated and we shouldn't use them anymore. So don't; appindicator/dbusmenu can handle GtkImages in normal GtkMenuItems now with the 16.04.0 release. appindicator/dbusmenu also strips Pango markup so we can remove the conditionals around label text.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7b440856..7e39955b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -104,6 +104,7 @@ GTK_CFLAGS="$GTK_CFLAGS -DGDK_VERSION_MIN_REQUIRED=GDK_VERSION_3_4"
AC_ARG_WITH([appindicator], AS_HELP_STRING([--with-appindicator|--without-appindicator], [Build with libappindicator support instead of xembed systray support.]))
if test "$with_appindicator" == "yes"; then
PKG_CHECK_MODULES(APPINDICATOR, appindicator3-0.1)
+ PKG_CHECK_MODULES(DBUSMENU, dbusmenu-gtk3-0.4 >= 16.04.0)
AC_DEFINE([ENABLE_INDICATOR], 1, [Enable using libappindicator])
fi