summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDan Williams <dcbw@redhat.com>2015-08-12 16:50:44 -0500
committerDan Williams <dcbw@redhat.com>2015-08-12 16:55:12 -0500
commit21319f4e975228bc11ec6cfa07ca5e3df927f715 (patch)
treee51f0401816cca3696759626c5f47185f24092ee /Makefile.am
parent80937b6339a47b98c51fcad1b30ab66b1cfe2be5 (diff)
data: don't put translations into the GSettings schema file
It's actually supposed to be handled through gettext and not put into the XML. A lot of projects are doing it wrong, and now glib-compile-schemas will yell at you. https://bugzilla.gnome.org/show_bug.cgi?id=747209
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 39433956..b82f57cd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -24,8 +24,8 @@ desktop_in_files = nm-connection-editor.desktop.in
desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
@INTLTOOL_DESKTOP_RULE@
-schema_in_files = org.gnome.nm-applet.gschema.xml.in
-gsettingsschema_DATA = $(schema_in_files:.xml.in=.xml)
+gsettings_SCHEMAS = org.gnome.nm-applet.gschema.xml
+@GSETTINGS_RULES@
appdatadir = $(datadir)/appdata
appdata_DATA = $(appdata_in_files:.xml.in=.xml)
@@ -38,7 +38,6 @@ convert_DATA=nm-applet.convert
DISTCHECK_CONFIGURE_FLAGS = --enable-more-warnings=yes
EXTRA_DIST += \
- $(schema_in_files) \
$(convert_DATA) \
$(appdata_in_files) \
$(autostart_in_files) \
@@ -48,6 +47,6 @@ CLEANFILES = \
$(autostart_DATA) \
$(desktop_DATA) \
$(appdata_DATA) \
- $(gsettingsschema_DATA)
+ $(BUILT_SOURCES)
DISTCLEANFILES = intltool-extract intltool-merge intltool-update