summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Biebl <biebl@debian.org>2016-04-26 16:41:30 +0200
committerMichael Biebl <biebl@debian.org>2016-04-26 16:41:32 +0200
commit5830d3f71a837778a3354467741122e51f867564 (patch)
treec93f4ce6034d17e7522eec81f32666094028ca9b
parent59167a49e82c10e85e136f9f06e6931bf769fd89 (diff)
Stop using -X for dh_install
Some files were not installed by accident because of that. Instead explicity remove .a and .la files and use --fail-missing while at it.
-rw-r--r--debian/changelog8
-rwxr-xr-xdebian/rules4
2 files changed, 11 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index cad6cddd..6616f9a2 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+network-manager-applet (1.2.0-2) UNRELEASED; urgency=medium
+
+ * Stop using -X for dh_install. Some files were not installed by accident
+ because of that. Instead explicity remove .a and .la files and use
+ --fail-missing while at it.
+
+ -- Michael Biebl <biebl@debian.org> Tue, 26 Apr 2016 16:40:17 +0200
+
network-manager-applet (1.2.0-1) unstable; urgency=medium
* New upstream release.
diff --git a/debian/rules b/debian/rules
index 7d208ce0..2fa57078 100755
--- a/debian/rules
+++ b/debian/rules
@@ -18,7 +18,9 @@ override_dh_auto_configure:
--with-wwan
override_dh_install:
- dh_install -X.la -X.a --list-missing
+ find debian/tmp -name '*.a' -delete
+ find debian/tmp -name '*.la' -delete
+ dh_install --fail-missing
override_dh_auto_test:
ifeq (, $(filter nocheck, $(DEB_BUILD_OPTIONS)))