summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRadoslaw Pajak <r.pajak@samsung.com>2013-08-23 12:40:57 +0200
committerLubomir Rintel <lkundrak@v3.sk>2015-02-11 11:44:59 +0100
commit76d9099ba18bca74e323004cb53ae262917a6677 (patch)
tree3a4093466b7fdff1fcd467d16ebf2f730d9c2899 /configure.ac
parent60cc51bd52699476248f0cf5bddb770a9d10e206 (diff)
dbus-daemon emulation improved and refactored
- added handling of GetId method of org.freedesktop.DBus - errors of org.freedesktop.DBus methods expanded to equal that of dbus-daemon - org.freedesktop.DBus emulation refactored and optimized - some minor fixes Change-Id: I1d9e670e36d6bc568518feacb6b14efc052ce735
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0d0d5d5d..b4c34fbc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1242,10 +1242,19 @@ if test x$with_valgrind != xno; then
AC_DEFINE([WITH_VALGRIND], [1], [Define to add Valgrind instrumentation])
fi
+### kdbus related libs
+AC_CHECK_LIB(crypto, MD5_Init,
+ [ AC_CHECK_HEADERS(openssl/md5.h, [],
+ [AC_MSG_ERROR([Could not find md5.h, check config.log for failed attempts])]) ],
+ [ AC_MSG_ERROR([Explicitly requested crypto but crypto not found]) ])
+KDBUS_LIBS="-lcrypto"
+#AC_SUBST([KDBUS_LIBS])
+
#### Set up final flags
-LIBDBUS_LIBS="$THREAD_LIBS $NETWORK_libs"
+LIBDBUS_LIBS="$THREAD_LIBS $NETWORK_libs $KDBUS_LIBS"
AC_SUBST([LIBDBUS_LIBS])
+
### X11 detection
DBUS_X_LIBS=
DBUS_X_CFLAGS=