summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChengwei Yang <chengwei.yang@intel.com>2013-10-08 21:59:37 +0800
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2013-10-08 16:08:57 +0100
commit47df159cc5b82d29588749b4dafedde33a8a3470 (patch)
treec89c33de840a9751386f7349549a80394753e8ca /configure.ac
parent5b74af796c8f1d9f3f60594f22c6bfd4c097ad8b (diff)
Unify the way to find dbus-daemon test binary
There are two ways to find the dbus-daemon for testing. The first one is defined as string at compile stage and the second one is export it from test environment. The first way has limitation that after defined, it's static string, so it's impossible to run installable check. So let's unify to the second way. Bug: https://bugs.freedesktop.org/show_bug.cgi?id=37849 [added missing "}" -smcv] Reviewed-by: Simon McVittie <simon.mcvittie@collabora.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 0 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 174308fb..923315e5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1617,10 +1617,6 @@ AC_DEFINE_UNQUOTED([DBUS_TEST_EXEC], ["$DBUS_TEST_EXEC"],
AC_DEFINE_UNQUOTED([DBUS_EXEEXT], ["$EXEEXT"],
[Extension for executables, typically empty or .exe])
-AC_DEFINE_UNQUOTED(TEST_BUS_BINARY, ["$DBUS_PWD/bus/dbus-daemon$EXEEXT"],
- [Full path to the daemon in the builddir])
-AC_SUBST(TEST_BUS_BINARY)
-
AC_DEFINE_UNQUOTED(TEST_BUS_LAUNCH_BINARY, ["$DBUS_PWD/tools/dbus-launch$EXEEXT"],
[Full path to the dbus-launch in the builddir])