summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCyril Brulebois <kibi@debian.org>2011-06-20 19:01:41 +0200
committerCyril Brulebois <kibi@debian.org>2011-06-20 19:19:05 +0200
commitc190732c5490a002b6ab8716c5392a7be1ade936 (patch)
treef7787bc40980025ac6a08c11f0b2eb77a9f6bc47
parent36b683daa4cd002bd575c6a7c5f8ab6d168f60b0 (diff)
Add a gentarball target.
-rw-r--r--debian/changelog3
-rwxr-xr-xdebian/rules7
2 files changed, 10 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 2018caa..2319405 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,5 +4,8 @@ wayland-demos (0.1.0~0-1) UNRELEASED; urgency=low
* Work around possible libegl1-mesa-dev bug (missing dependency on
libegl1-mesa-drivers).
* Use explicit dependencies on the egl1/gles2 packages.
+ * debian/rules contains a gentarball target to create a tarball from the
+ upstream-experimental branch, to be used until some upstream release
+ happens.
-- Cyril Brulebois <kibi@debian.org> Thu, 16 Jun 2011 14:08:14 +0200
diff --git a/debian/rules b/debian/rules
index bd58741..3324803 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,5 +1,7 @@
#!/usr/bin/make -f
+SOURCE=wayland-demos
+
# Enable/disable features explicitly:
override_dh_auto_configure:
dh_auto_configure -- \
@@ -25,3 +27,8 @@ override_dh_makeshlibs:
%:
dh $@ --with quilt,autoreconf --builddirectory=build/
+
+# For maintainer use only, generate a tarball:
+gentarball: UV=$(shell dpkg-parsechangelog|awk '/^Version:/ {print $$2}'|sed 's/-.*$$//')
+gentarball:
+ git archive --format=tar upstream-experimental --prefix=$(SOURCE)-$(UV)/ | gzip -9 > ../$(SOURCE)_$(UV).orig.tar.gz