summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--tests/Makefile.am13
1 files changed, 2 insertions, 11 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 01ca8b4b..bf1987f1 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -10,10 +10,10 @@ check_PROGRAMS = \
dristat \
drmstat
-SUBDIRS =
+SUBDIRS = modeprint
if HAVE_LIBKMS
-SUBDIRS += kmstest
+SUBDIRS += kmstest modetest
endif
if HAVE_LIBUDEV
@@ -47,15 +47,6 @@ TESTS = \
SUBDIRS += vbltest $(NULL)
if HAVE_INTEL
-if HAVE_LIBKMS
-SUBDIRS += \
- modetest
-endif
-
-SUBDIRS += \
- modeprint \
- $(NULL)
-
TESTS += \
gem_basic \
gem_flink \