summaryrefslogtreecommitdiff
path: root/ChangeLog
diff options
context:
space:
mode:
Diffstat (limited to 'ChangeLog')
-rw-r--r--ChangeLog641
1 files changed, 635 insertions, 6 deletions
diff --git a/ChangeLog b/ChangeLog
index 5c4b69e..10a0b43 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,5 +1,634 @@
# Generated by configure. Do not edit.
+commit 4938e11ffe11781e4e294092807ebc67f362eac6
+Author: Chris Wilson <chris@chris-wilson.co.uk>
+Date: Sat Dec 25 13:25:14 2010 +0000
+
+ version: Bump for 1.10.2 release
+
+ cairo-version.h | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+commit de464ea7781707984a1e1d5f98a8ff23c5ee18ed
+Author: Chris Wilson <chris@chris-wilson.co.uk>
+Date: Sat Dec 25 13:24:37 2010 +0000
+
+ NEWS: Add entry for 1.10.2
+
+ NEWS | 59 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
+ 1 files changed, 59 insertions(+), 0 deletions(-)
+
+commit 888eeb187f542b96e722725f616720038e700b84
+Author: Chris Wilson <chris@chris-wilson.co.uk>
+Date: Sat Dec 25 10:19:38 2010 +0000
+
+ Add a KNOWN_ISSUES file to track WONTFIX(?) bugs
+
+ KNOWN_ISSUES | 10 ++++++++++
+ Makefile.am | 1 +
+ 2 files changed, 11 insertions(+), 0 deletions(-)
+
+commit a27e3bc6d08feeac8e4ee5315a0ad974efee0ee9
+Author: Koji Otani <sho@bbr.jp>
+Date: Wed Nov 17 00:07:03 2010 +1030
+
+ PS: fix embedding of grayscale jpegs
+
+ https://bugs.freedesktop.org/show_bug.cgi?id=31632
+ (cherry picked from commit 653ceb517fe756b042a3cf8322a36cbfe71ddbd8)
+
+ src/cairo-ps-surface.c | 5 +++--
+ 1 files changed, 3 insertions(+), 2 deletions(-)
+
+commit 4aabff8f6740e2027febd97c1863f7ba5a46cb92
+Author: Andrea Canciani <ranma42@gmail.com>
+Date: Tue Dec 14 17:56:00 2010 +0100
+
+ path-bounder: Update current point after curve_to op
+
+ Even if the curve_to is completely within the current extents box, the
+ current point needs to be updated because the shape of following ops
+ depends on the position of the current point.
+
+ Fixes bug-extents.
+
+ src/cairo-path-bounds.c | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+commit 5996652364efa4fb4ae6c984ddf6ddad8868782b
+Author: Andrea Canciani <ranma42@gmail.com>
+Date: Tue Dec 14 20:15:28 2010 +0100
+
+ test: Add bug-extents
+
+ Add a test for the computation of approximate extents used by most
+ backends to esimate the region affected by drawing operations.
+
+ Based on:
+ http://lists.cairographics.org/archives/cairo/2010-December/021331.html
+
+ test/Makefile.am | 5 +++
+ test/Makefile.sources | 1 +
+ test/bug-extents.c | 59 ++++++++++++++++++++++++++++++++++++++
+ test/bug-extents.image16.ref.png | Bin 0 -> 7576 bytes
+ test/bug-extents.ps.ref.png | Bin 0 -> 5844 bytes
+ test/bug-extents.quartz.ref.png | Bin 0 -> 9310 bytes
+ test/bug-extents.ref.png | Bin 0 -> 9162 bytes
+ test/bug-extents.xlib.ref.png | Bin 0 -> 9234 bytes
+ 8 files changed, 65 insertions(+), 0 deletions(-)
+
+commit f832ff7f22499bfa8e907f9fb059d56857d11e68
+Author: Andrea Canciani <ranma42@gmail.com>
+Date: Sun Nov 28 16:58:20 2010 +0100
+
+ test: Fix ref images
+
+ The corners of the boxes in these ref images were not correct.
+
+ test/clip-stroke.image16.ref.png | Bin 1308 -> 1305 bytes
+ test/clip-stroke.ref.png | Bin 1442 -> 1447 bytes
+ test/clipped-group.image16.ref.png | Bin 281 -> 270 bytes
+ test/clipped-group.ref.png | Bin 289 -> 289 bytes
+ 4 files changed, 0 insertions(+), 0 deletions(-)
+
+commit ff35af3fd73e59ea29b1a322c833f7dd24b0b8bc
+Author: Andrea Canciani <ranma42@gmail.com>
+Date: Sun Nov 28 14:32:51 2010 +0100
+
+ image: Fix compositing of unaligned boxes
+
+ The input of _fill_unaligned_boxes is (supposed to be) composed only
+ of disjoint rectangles, that can safely be passed to the rectilinear
+ span converter, but this function artificially introduces intersecting
+ rectangles when drawing non-aligned boxes.
+
+ Using non-intersecting rectangles is easy and makes the code correct.
+
+ Fixes rectilinear-grid.
+
+ Reviewed-by: Uli Schlachter <psychon@znc.in>
+
+ src/cairo-image-surface.c | 22 ++++++++++++++--------
+ 1 files changed, 14 insertions(+), 8 deletions(-)
+
+commit 7b29f1d5d85ebb7e92e9759692233c80a4687a07
+Author: Andrea Canciani <ranma42@gmail.com>
+Date: Fri Nov 26 17:55:35 2010 +0100
+
+ test: Add rectilinear-grid
+
+ The rectilinear scan converter assumes disjoint rects as input, but
+ cairo-image passes intersecting rectangles to it.
+
+ This test shows that image and any backends passing through it for the
+ rasterization (fallbacks, vector backends whose renderer is
+ cairo-based) fail in compute the corners of intersecting rectangles
+ correctly.
+
+ test/Makefile.am | 2 +
+ test/Makefile.sources | 1 +
+ test/rectilinear-grid.c | 78 +++++++++++++++++++++++++++++++++
+ test/rectilinear-grid.image16.ref.png | Bin 0 -> 638 bytes
+ test/rectilinear-grid.ref.png | Bin 0 -> 569 bytes
+ 5 files changed, 81 insertions(+), 0 deletions(-)
+
+commit 9ec51baa779a30041ea944643d4d0b8333bb759b
+Author: Adrian Johnson <ajohnson@redneon.com>
+Date: Fri Nov 26 21:41:17 2010 +1030
+
+ PDF: Add missing clipper_reset
+ (cherry picked from commit 2ae2be36d4551906fd4edbc8bf07aaa7fe0c93cf)
+
+ src/cairo-pdf-surface.c | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+commit 841a2df7359e2b491aed7ed8c043cce669357ae3
+Author: Markus Stange <mstange@themasta.com>
+Date: Fri Nov 5 09:23:44 2010 +0100
+
+ Fix type of _cairo_memory_stream_destroy parameter
+
+ In 9b9952ab4f64a476bbadfd3e6cf1e66c1137ccd7
+ _cairo_memory_stream_destroy was changed to take an unsigned long
+ instead of unsigned int, and the two callsites in cairo-gl-shaders.c
+ weren't updated.
+
+ src/cairo-gl-shaders.c | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+commit b6a97499c71af60a3f15d131d51eb53fb21b48ff
+Author: Andrea Canciani <ranma42@gmail.com>
+Date: Tue Oct 5 10:36:38 2010 +0200
+
+ xcb: Do not return value in void function
+
+ Sun Studio Compiler complains:
+ "cairo-xcb-surface.c", line 585: void function cannot return value
+ even if the returned value is void.
+ Some minor code restructuring removes the issue.
+
+ src/cairo-xcb-surface.c | 10 ++++------
+ 1 files changed, 4 insertions(+), 6 deletions(-)
+
+commit e71588c80d5c6112fa9f7c6ea369d90f9284199f
+Author: Andrea Canciani <ranma42@gmail.com>
+Date: Sun Oct 24 16:40:53 2010 +0200
+
+ test: Add romedalen images copyright information
+
+ romedalen.png and romedalen.jpg have been bundled into the test
+ suite without an explicit copyright notice.
+
+ test/COPYING | 13 +++++++++++++
+ 1 files changed, 13 insertions(+), 0 deletions(-)
+
+commit 2b3d8de11a536d668084ea6d2bf295da1d1cdc11
+Author: Andrea Canciani <ranma42@gmail.com>
+Date: Sat Oct 16 22:51:28 2010 +0200
+
+ Fix degenerate arcs
+
+ Make sure that degenerate arcs become a move_to-line_to sequence
+ instead of just a move_to.
+
+ Fixes get-path-extents.
+
+ src/cairo-arc.c | 4 ++++
+ src/cairo.c | 1 +
+ 2 files changed, 5 insertions(+), 0 deletions(-)
+
+commit fafca7ace250e3f4f9c60584f0ddff187c690068
+Author: Joerg Sonnenberger <joerg@NetBSD.org>
+Date: Tue Oct 12 22:07:37 2010 +0200
+
+ LD_PRELOAD is supported on DragonFly.
+
+ configure.ac | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+commit c20d55eb1c1eb1c6f51a21c7eb205ba4c2c125e8
+Author: Erik Zeek <zeekec@mad.scientist.com>
+Date: Thu Nov 4 17:57:03 2010 +0100
+
+ Fix build on gentoo
+
+ The problem is probably caused by a change in the behavior of autoconf
+ (2.67).
+
+ See http://bugs.gentoo.org/336329
+
+ configure.ac | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+commit 8ef5161da307361e20dad68df74512c5afcbb012
+Author: Andrea Canciani <ranma42@gmail.com>
+Date: Sat Nov 6 15:46:48 2010 +0100
+
+ configure: Correct reporting of tee backend
+
+ Since 9f33f8453b4949cfdc63169d3acd7238f89379c2 tee is not compiled in
+ anymore by default. Reporting it as always enabled is misleading.
+
+ build/configure.ac.features | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+commit a6b503961b7ffd6a0725ad7d98ec1c46e2f15f25
+Author: Andrea Canciani <ranma42@gmail.com>
+Date: Mon Nov 22 23:41:33 2010 +0100
+
+ ps: Fix painting
+
+ Painting of some pattern was broken because the paint operation was
+ implemented as a fill to a rect containing the clip, but this rect was
+ not transformed as appropriate (using the cairo_to_ps matrix).
+ PDF simply fills the whole surface rect, so we implement the same
+ behavior in PS.
+
+ Fixes clip-group-shapes-circles, clip-stroke, linear-gradient-extend,
+ linear-gradient-one-stop, radial-gradient-one-stop.
+
+ src/cairo-ps-surface.c | 5 ++---
+ 1 files changed, 2 insertions(+), 3 deletions(-)
+
+commit b8347e33539402ef64d652bc0f67522e4d02d51c
+Author: Adrian Johnson <ajohnson@redneon.com>
+Date: Sun Nov 21 00:37:29 2010 +1030
+
+ PS: Fix regression - incorrect EPS bounding box
+
+ https://bugs.freedesktop.org/show_bug.cgi?id=24688
+ (cherry picked from commit bb4055dac6a937b3412170a332b5effe4bbeff7d)
+
+ src/cairo-analysis-surface.c | 40 ++++++++++------------------------------
+ 1 files changed, 10 insertions(+), 30 deletions(-)
+
+commit cfff4f30a0eaa29b817cb32616c2da5a27921332
+Author: Adrian Johnson <ajohnson@redneon.com>
+Date: Sat Nov 20 23:54:00 2010 +1030
+
+ PS: Fix regression - missing page content in EPS output
+
+ https://bugs.freedesktop.org/show_bug.cgi?id=24688
+ (cherry picked from commit d3746448d78fcedf8f8f9a7d0fca47f1bd6a5b67)
+
+ src/cairo-ps-surface.c | 9 ---------
+ 1 files changed, 0 insertions(+), 9 deletions(-)
+
+commit ed87ddddb3994f126e0f2d18fa23da6bc5ed579e
+Author: Adrian Johnson <ajohnson@redneon.com>
+Date: Sat Nov 20 00:50:04 2010 +1030
+
+ PS/PDF: Fix regression when changing page size to a larger size
+
+ https://bugs.freedesktop.org/show_bug.cgi?id=24691
+ (cherry picked from commit e7c5f470436220668e50201d775a9fec47162a67)
+
+ src/cairo-paginated-surface.c | 28 ++++++++++++++++++++++++++++
+ src/cairo-pdf-surface.c | 10 ++++++++--
+ src/cairo-ps-surface.c | 6 ++++++
+ 3 files changed, 42 insertions(+), 2 deletions(-)
+
+commit ccff76433e1cd068e5534d0ab633c27b0faf47d2
+Author: Adrian Johnson <ajohnson@redneon.com>
+Date: Wed Nov 10 20:09:53 2010 +1030
+
+ PDF: Restrict ActualText to PDF version >= 1.5
+
+ The use of ActualText in a marked content sequence is a PDF 1.5
+ feature.
+
+ A 'use_actual_text' flag linked to the PDF version has already been
+ implemented in pdf-operators but for some reason this flag had not
+ been used to control the use of ActualText.
+ (cherry picked from commit 3afd7cd031ab9097e37c3e89d86ec41d015fdeb8)
+
+ src/cairo-pdf-operators.c | 31 ++++++++++++++++++-------------
+ 1 files changed, 18 insertions(+), 13 deletions(-)
+
+commit e0967ff83c24aaf6d6b3a93a627872820be9012b
+Author: Adrian Johnson <ajohnson@redneon.com>
+Date: Sat Nov 6 21:15:30 2010 +1030
+
+ Fix type1-fallback bbox
+ (cherry picked from commit 74873c82242e9c124b69e05d0f8abdf78983d62d)
+
+ src/cairo-type1-fallback.c | 8 ++++----
+ 1 files changed, 4 insertions(+), 4 deletions(-)
+
+commit 1413a44f64982e5196ca338c7cee5dfe19cd4b40
+Author: Adrian Johnson <ajohnson@redneon.com>
+Date: Sat Nov 6 18:44:54 2010 +1030
+
+ configure.ac.features: s/Meta/Recording/
+ (cherry picked from commit 8f2f5e5ad4f8e5f18da903865bb2d2afce3a544e)
+
+ build/configure.ac.features | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+commit e9bb70d2dee4ef7a54e3971f09a08df30c2b5287
+Author: Jeff Muizelaar <jmuizelaar@mozilla.com>
+Date: Fri Nov 5 11:40:00 2010 -0400
+
+ Fix degenerate vertical path bounds.
+
+ 6b77567b6ef28710c7707ab82c7fa95c810152d1 made vertical
+ path bounds with no area return extents of 0,0. This fixes
+ the problem by not assuming degenerate path bounds are 0,0
+
+ src/cairo-path-bounds.c | 4 +++-
+ test/get-path-extents.c | 40 ++++++++++++++++++++++++++++++++--------
+ 2 files changed, 35 insertions(+), 9 deletions(-)
+
+commit 91a6fe64236985d30f5794d760698deafd9e6511
+Author: Andrea Canciani <ranma42@gmail.com>
+Date: Mon Nov 1 21:15:07 2010 +0100
+
+ image: Use correct size for allocation
+
+ In 06e9caf86199e8261a07db6d4774628fa147728d the type of the variables
+ was changed, but the type used to compute the allocation size was not.
+
+ Fixes a crash in user-font-mask (test-fallback backend).
+ (cherry picked from commit c7027c9d89d9a13d6cbc1727fc8513c908878db9)
+
+ src/cairo-image-surface.c | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+commit 83259f6ed60e00d0c25ca81c9ff9adfc017ebf5f
+Author: Benjamin Otte <otte@redhat.com>
+Date: Thu Oct 28 13:57:05 2010 +0200
+
+ build: Don't build cairo-fdr when the tee surface is off
+
+ util/Makefile.am | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+commit efc2440526c609338d68354ddf38031d1fa7c2c4
+Author: Adrian Johnson <ajohnson@redneon.com>
+Date: Thu Oct 28 21:21:00 2010 +1030
+
+ PDF: Don't use the currently set color after a 'Q' operator
+
+ https://bugs.freedesktop.org/show_bug.cgi?id=31140
+ (cherry picked from commit e23bcfd4300870034f07b1ecd1bb4d2ac95d9785)
+
+ src/cairo-pdf-surface.c | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+commit f47830dbbc34c7068ccdd8f7f9042e8734c9e408
+Author: Adrian Johnson <ajohnson@redneon.com>
+Date: Sun Oct 24 11:32:41 2010 +1030
+
+ Type 1 subset: Fix glyph advance
+
+ https://bugs.freedesktop.org/show_bug.cgi?id=31062
+ (cherry picked from commit 6dc0b19adb6da690ad5944623081b9cdb42de066)
+
+ src/cairo-type1-subset.c | 30 +++++++++++++++---------------
+ 1 files changed, 15 insertions(+), 15 deletions(-)
+
+commit f747ea81fb91239690b1785bce9ed29cb58c9098
+Author: Adrian Johnson <ajohnson@redneon.com>
+Date: Thu Oct 14 19:28:13 2010 +1030
+
+ PDF: Fix regression in EXTEND_NONE gradients
+
+ The test for opaque gradients in _cairo_pdf_surface_add_pdf_pattern()
+ must be identical to the test in
+ _cairo_pdf_surface_emit_pattern_stops() other wise the PDF file will
+ reference a smask that does not exist.
+
+ The _cairo_pattern_is_opaque() test is too strict for PDF as PDF can
+ draw EXTEND_NONE gradients with opaque color stops without requiring a
+ smask.
+ (cherry picked from commit 7a17ef31760c49b81fd2890814f5b2aeb8c6b3a3)
+
+ src/cairo-pdf-surface.c | 15 ++++++++++++++-
+ 1 files changed, 14 insertions(+), 1 deletions(-)
+
+commit 7450a3c8a7843334d6e16af3ecef88915b5d9f26
+Author: Adrian Johnson <ajohnson@redneon.com>
+Date: Fri Oct 1 19:18:28 2010 +0930
+
+ pdf-operators: fix bug that was causing unnecessary repositioning of text
+
+ This optimizes the output to increase the maximum amount of text that
+ is emitted with a single Tj operator.
+ (cherry picked from commit 165a14b5646d582781d119874f549ec9a02d7f53)
+
+ src/cairo-pdf-operators-private.h | 1 +
+ src/cairo-pdf-operators.c | 7 ++++++-
+ 2 files changed, 7 insertions(+), 1 deletions(-)
+
+commit 43c93f2b101f534f8aa4213403af3281fcdc17fb
+Author: Adrian Johnson <ajohnson@redneon.com>
+Date: Fri Oct 1 17:41:28 2010 +0930
+
+ Fix font metrics in PDF Type 1 fonts
+
+ edcefa87 introduced a bug in the Type 1 font metrics in PDF files.
+ (cherry picked from commit 3f817dcfd39ffdb73ac694fd90a47d9d3a42af74)
+
+ src/cairo-type1-subset.c | 12 ++++++------
+ 1 files changed, 6 insertions(+), 6 deletions(-)
+
+commit 66ace8cd33c0ebe88972f0c4d5c0effeacb1cea3
+Author: Chris Wilson <chris@chris-wilson.co.uk>
+Date: Wed Sep 29 13:46:02 2010 +0100
+
+ image: The a8 in-place span compositing is only valid for SOURCE
+
+ Fixes test/a8-clear.
+
+ Reported-by: Jeremy Moles <jeremy@emperorlinux.com>
+ Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
+
+ src/cairo-image-surface.c | 9 +++++++--
+ 1 files changed, 7 insertions(+), 2 deletions(-)
+
+commit 05faebd5845c68005f5b96428952faae5a67208f
+Author: Chris Wilson <chris@chris-wilson.co.uk>
+Date: Wed Sep 29 13:23:24 2010 +0100
+
+ test: Add a8-clear
+
+ Reported-by: Jeremy Moles <jeremy@emperorlinux.com>
+ Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
+
+ test/Makefile.am | 1 +
+ test/Makefile.sources | 1 +
+ test/a8-clear.c | 64 +++++++++++++++++++++++++++++++++++++++++++++++++
+ test/a8-clear.ref.png | Bin 0 -> 271 bytes
+ 4 files changed, 66 insertions(+), 0 deletions(-)
+
+commit ac6fd51fe4e500973e0939983d00aa81c8acf556
+Author: Chris Wilson <chris@chris-wilson.co.uk>
+Date: Wed Sep 29 13:25:08 2010 +0100
+
+ image: Silence a compile warning
+
+ cairo-image-surface.c: In function ‘_cairo_image_reset_static_data’:
+ cairo-image-surface.c:1006: warning: old-style function definition
+
+ Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
+
+ src/cairo-image-surface.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+commit 75e2b7c7b52be6663fac05925b9b4cc5f3b42f9f
+Author: Tim Janik <timj@gtk.org>
+Date: Thu Sep 23 13:55:11 2010 +0200
+
+ cairo: docu fix for cairo_set_source_surface
+
+ src/cairo.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+commit 4cf5260e99e3e7588e45ee179c57b75588b95987
+Author: Kouhei Sutou <kou@cozmixng.org>
+Date: Sun Sep 12 10:36:27 2010 +0900
+
+ xml: fix a typo to correct the indentation after <path></path>
+
+ Signed-off-by: Kouhei Sutou <kou@cozmixng.org>
+
+ src/cairo-xml-surface.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+commit 0f070bd5ff9ad17b90852e8a7ba102c6b4b050f6
+Author: Tomáš Chvátal <scarabeus@gentoo.org>
+Date: Sat Sep 11 22:55:23 2010 +0200
+
+ Fix posix calls in configure.ac test code.
+
+ Fixes https://bugs.gentoo.org/show_bug.cgi?id=336779
+
+ Signed-off-by: Tomáš Chvátal <scarabeus@gentoo.org>
+
+ configure.ac | 8 ++++----
+ 1 files changed, 4 insertions(+), 4 deletions(-)
+
+commit f59771051badc2ea708437c5faa27d0895f787d6
+Author: Chris Wilson <chris@chris-wilson.co.uk>
+Date: Wed Aug 18 08:48:36 2010 +0100
+
+ drm: Add missing header file for tarball
+
+ src/Makefile.sources | 7 ++++---
+ 1 files changed, 4 insertions(+), 3 deletions(-)
+
+commit 8fca990be7fca609e834703e60dd888c13fc637f
+Author: Chris Wilson <chris@chris-wilson.co.uk>
+Date: Fri Sep 10 13:35:11 2010 +0100
+
+ cairo: Remove trailing comma from cairo_device_t
+
+ Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=30115
+ Reported-by: Murray Cumming <murrayc@murrayc.com>
+
+ src/cairo.h | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+commit 291876ad3477330143bbb814ea72c658dc8ca584
+Author: Andrea Canciani <ranma42@gmail.com>
+Date: Thu Sep 9 22:53:38 2010 +0200
+
+ test: do not leak resources
+
+ Silence some leak reports by check-valgrind.
+
+ test/subsurface-outside-target.c | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+commit 8fda4ab1cc7f60196b232d194c33e592ecdec9b5
+Author: Andrea Canciani <ranma42@gmail.com>
+Date: Thu Aug 26 11:15:46 2010 +0200
+
+ image: add _cairo_image_reset_static_data
+
+ Image has static caches which needs to be reset to make
+ cairo_debug_reset_static_data behave as expected.
+ Silences a bunch of leak reports by check-valgrind.
+
+ Reviewed-by: Chris Wilson <chris@chris-wilson.co.uk>
+
+ src/cairo-debug.c | 2 ++
+ src/cairo-image-surface.c | 42 ++++++++++++++++++++++++++++++++++--------
+ src/cairoint.h | 3 +++
+ 3 files changed, 39 insertions(+), 8 deletions(-)
+
+commit ca775cbf5a7245092cabdda43db9d06e96613ff4
+Author: Andrea Canciani <ranma42@gmail.com>
+Date: Thu Aug 26 11:13:51 2010 +0200
+
+ test: do not leak resources
+
+ Silence two leak reports by check-valgrind.
+
+ Reviewed-by: Chris Wilson <chris@chris-wilson.co.uk>
+
+ test/linear-gradient-large.c | 1 +
+ test/nil-surface.c | 3 ++-
+ 2 files changed, 3 insertions(+), 1 deletions(-)
+
+commit 2b6c4c2a64c585cb815089e83719e00b1cfc985f
+Author: Carlos Garcia Campos <carlosgc@gnome.org>
+Date: Thu Sep 9 11:28:03 2010 +0200
+
+ recording: Document CAIRO_HAS_RECORDING_SURFACE macro
+
+ src/cairo-recording-surface.c | 10 ++++++++++
+ 1 files changed, 10 insertions(+), 0 deletions(-)
+
+commit d8f88cf3f97af6771a4d77bf81e1025eb7bcfd1d
+Author: Carlos Garcia Campos <carlosgc@gnome.org>
+Date: Thu Sep 9 11:00:42 2010 +0200
+
+ recording: Fix cairo_recording_surface_create() doc comments
+
+ The name of the parameters in the docs should match the name of the
+ function parameters. Added also return value docs.
+
+ src/cairo-recording-surface.c | 10 +++++++---
+ 1 files changed, 7 insertions(+), 3 deletions(-)
+
+commit 737880260f1895667baf25bcc6814052e6a6a027
+Author: Carlos Garcia Campos <carlosgc@gnome.org>
+Date: Thu Sep 9 10:57:13 2010 +0200
+
+ recording: Add section doc comments
+
+ src/cairo-recording-surface.c | 10 +++++++---
+ 1 files changed, 7 insertions(+), 3 deletions(-)
+
+commit 1ddc1bfa01e4c17001504c886bc5fb97625f5861
+Author: Carlos Garcia Campos <carlosgc@gnome.org>
+Date: Thu Sep 9 10:54:50 2010 +0200
+
+ doc: Add section for recording surface
+
+ doc/public/cairo-docs.xml | 1 +
+ doc/public/cairo-sections.txt | 7 +++++++
+ 2 files changed, 8 insertions(+), 0 deletions(-)
+
+commit a48eccbf77874e00a57ab7f1ab96ed0f359b3963
+Author: Chris Wilson <chris@chris-wilson.co.uk>
+Date: Tue Sep 7 13:58:29 2010 +0100
+
+ configure: Fix typo "(requires both --enable-xcb)"
+
+ configure.ac | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+commit faeb6caaeba76c9797db0cd917bff4f102512d59
+Author: Chris Wilson <chris@chris-wilson.co.uk>
+Date: Mon Sep 6 18:40:27 2010 +0100
+
+ version: 1.10.1 open for bugfixing
+
+ cairo-version.h | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
commit cb0bc64c16b3a38cbf0c622830c18ac9ea6e2ffe
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date: Mon Sep 6 17:15:51 2010 +0100
@@ -7041,7 +7670,7 @@ Date: Fri Mar 26 19:37:08 2010 +0000
src/drm/cairo-drm-i915-private.h | 153 ++-
src/drm/cairo-drm-i915-shader.c | 866 +++++++-----
src/drm/cairo-drm-i915-spans.c | 146 ++-
- src/drm/cairo-drm-i915-surface.c | 1884 ++++++++++++++++++------
+ src/drm/cairo-drm-i915-surface.c | 1698 +++++++++++++++++-----
src/drm/cairo-drm-i965-glyphs.c | 36 +-
src/drm/cairo-drm-i965-private.h | 2 +-
src/drm/cairo-drm-i965-shader.c | 11 +-
@@ -7056,7 +7685,7 @@ Date: Fri Mar 26 19:37:08 2010 +0000
src/drm/cairo-drm-radeon-surface.c | 60 +-
src/drm/cairo-drm-surface.c | 37 +-
src/drm/cairo-drm-xr.c | 2377 +++++++++++++++++++++++++++++++
- 38 files changed, 5416 insertions(+), 1404 deletions(-)
+ 38 files changed, 5323 insertions(+), 1311 deletions(-)
commit c8fba4960339797521afbf8068fcbe62d064f5dc
Author: Chris Wilson <chris@chris-wilson.co.uk>
@@ -13724,13 +14353,13 @@ Date: Fri Jan 22 21:26:26 2010 +0000
src/cairo-xcb-surface-core.c | 613 +++++
src/cairo-xcb-surface-private.h | 37 +
src/cairo-xcb-surface-render.c | 4471 +++++++++++++++++++++++++++++++++++
- src/cairo-xcb-surface.c | 3382 ++++++++-------------------
+ src/cairo-xcb-surface.c | 3344 +++++++-------------------
src/cairo-xcb-xrender.h | 63 -
src/cairo-xcb.h | 41 +-
src/cairo-xlib-xcb-surface.c | 515 ++++
src/cairoint.h | 16 +
test/xcb-surface-source.c | 1 -
- 28 files changed, 11708 insertions(+), 2571 deletions(-)
+ 28 files changed, 11689 insertions(+), 2552 deletions(-)
commit 77afe8491ed7038a8399c01f10d8f062a7239225
Author: Chris Wilson <chris@chris-wilson.co.uk>
@@ -13820,7 +14449,7 @@ Date: Fri Jan 22 17:57:41 2010 +0000
image-rgba firefox-talos-svg-0 375273.43 (388250.94 1.60%) -> 356846.09 (370370.08 1.86%): 1.05x speedup
- src/cairo-image-surface.c | 3987 ++++++++++++++++++++++++-----
+ src/cairo-image-surface.c | 3893 ++++++++++++++++++++++++-----
src/cairo-mutex-list-private.h | 2 +
src/cairo-xcb-surface.c | 10 +-
src/cairoint.h | 21 +-
@@ -13834,7 +14463,7 @@ Date: Fri Jan 22 17:57:41 2010 +0000
test/scale-offset-image.xfail.png | Bin 9960 -> 9961 bytes
test/scale-offset-similar.xfail.png | Bin 9960 -> 9961 bytes
test/self-intersecting.ref.png | Bin 213 -> 168 bytes
- 14 files changed, 3342 insertions(+), 678 deletions(-)
+ 14 files changed, 3295 insertions(+), 631 deletions(-)
commit ec7cc9dea16f94e1e56720be548cf5520ec4708b
Author: Chris Wilson <chris@chris-wilson.co.uk>