summaryrefslogtreecommitdiff
path: root/build
diff options
context:
space:
mode:
authorSebastian Dröge <sebastian.droege@collabora.co.uk>2010-06-26 16:04:51 +0200
committerSebastian Dröge <sebastian.droege@collabora.co.uk>2010-06-26 16:04:51 +0200
commit342796e34d0c9374c51f2ab70a85c5a9f6b97700 (patch)
treedcac6d41b5f63e12f3631f7e6c352378d480dae3 /build
parent728b3091c142e918935200adcd4facfec7ccd515 (diff)
Import upstream version 1.9.10
Diffstat (limited to 'build')
-rw-r--r--build/Makefile.win32.features1
-rw-r--r--build/Makefile.win32.features-h3
-rw-r--r--build/configure.ac.features1
3 files changed, 5 insertions, 0 deletions
diff --git a/build/Makefile.win32.features b/build/Makefile.win32.features
index 5c283ac..1d6fd8c 100644
--- a/build/Makefile.win32.features
+++ b/build/Makefile.win32.features
@@ -24,6 +24,7 @@ CAIRO_HAS_DIRECTFB_SURFACE=0
CAIRO_HAS_VG_SURFACE=0
CAIRO_HAS_EGL_FUNCTIONS=0
CAIRO_HAS_GLX_FUNCTIONS=0
+CAIRO_HAS_WGL_FUNCTIONS=0
CAIRO_HAS_SCRIPT_SURFACE=0
CAIRO_HAS_FT_FONT=0
CAIRO_HAS_FC_FONT=0
diff --git a/build/Makefile.win32.features-h b/build/Makefile.win32.features-h
index 1e66889..9d9468c 100644
--- a/build/Makefile.win32.features-h
+++ b/build/Makefile.win32.features-h
@@ -77,6 +77,9 @@ endif
ifeq ($(CAIRO_HAS_GLX_FUNCTIONS),1)
@echo "#define CAIRO_HAS_GLX_FUNCTIONS 1" >> src/cairo-features.h
endif
+ifeq ($(CAIRO_HAS_WGL_FUNCTIONS),1)
+ @echo "#define CAIRO_HAS_WGL_FUNCTIONS 1" >> src/cairo-features.h
+endif
ifeq ($(CAIRO_HAS_SCRIPT_SURFACE),1)
@echo "#define CAIRO_HAS_SCRIPT_SURFACE 1" >> src/cairo-features.h
endif
diff --git a/build/configure.ac.features b/build/configure.ac.features
index 1e40de8..1473bd7 100644
--- a/build/configure.ac.features
+++ b/build/configure.ac.features
@@ -390,6 +390,7 @@ AC_DEFUN([CAIRO_REPORT],
echo " PNG functions: $use_png"
echo " GLEW functions: $use_glew"
echo " GLX functions: $use_glx"
+ echo " WGL functions: $use_wgl"
echo " EGL functions: $use_egl"
echo " X11-xcb functions: $use_xlib_xcb"
echo " XCB-drm functions: $use_xcb_drm"