summaryrefslogtreecommitdiff
path: root/build
diff options
context:
space:
mode:
authorCyril Brulebois <kibi@debian.org>2011-06-20 01:53:48 +0200
committerCyril Brulebois <kibi@debian.org>2011-06-20 01:53:48 +0200
commit33cc97022c22336d56b8875d041b55877199e9e7 (patch)
tree4d31aabc4d13416d59b4acc1934c16eb973eddad /build
parent71431660470357a652819295118cb92d0e5d0e80 (diff)
Import upstream release 1.11.21.11.2upstream-experimental
Diffstat (limited to 'build')
-rw-r--r--build/Makefile.am.gtk-doc11
-rw-r--r--build/configure.ac.features1
-rw-r--r--build/configure.ac.warnings4
3 files changed, 13 insertions, 3 deletions
diff --git a/build/Makefile.am.gtk-doc b/build/Makefile.am.gtk-doc
index 7161702..c3d642b 100644
--- a/build/Makefile.am.gtk-doc
+++ b/build/Makefile.am.gtk-doc
@@ -1,7 +1,16 @@
-# Modified for cairo minimally:
+# BEFORE MODIFYING THIS FILE:
+#
+# This file is a descendant of an old copy of gtk-doc.make, modified for cairo minimally:
+#
# - Moved to build/
# - Made it append to EXTRA_DIST and CLEANFILES
# - Instead of all-local, make "doc" build docs, and err if gtk-doc not enabled
+# - Some other changed introduced in 7f114b781f5c530d57530e5f76402e41cdabac6b
+#
+# Before changing it, check to see if a newer gtk-doc.make has fixed the issue you are facing.
+# From time to time, it would be nice to udpate this to the latest copy of gtk-doc.make, but
+# please do review all the differences and port our modifications forward.
+#
# -*- mode: makefile -*-
diff --git a/build/configure.ac.features b/build/configure.ac.features
index dc3c8b8..343442a 100644
--- a/build/configure.ac.features
+++ b/build/configure.ac.features
@@ -395,7 +395,6 @@ AC_DEFUN([CAIRO_REPORT],
echo ""
echo "The following functions:"
echo " PNG functions: $use_png"
- echo " GLEW functions: $use_glew"
echo " GLX functions: $use_glx"
echo " WGL functions: $use_wgl"
echo " EGL functions: $use_egl"
diff --git a/build/configure.ac.warnings b/build/configure.ac.warnings
index b225ac8..a43ae89 100644
--- a/build/configure.ac.warnings
+++ b/build/configure.ac.warnings
@@ -8,6 +8,8 @@ dnl MAYBE_WARN in an ignorable way (like adding whitespace)
# -Wcast-align generates lots of false positive reports we need to
# cast image data from uint8_t to uin32_t.
+# -Wlogical-op causes too much noise from strcmp("literal", str)
+
MAYBE_WARN="-Wall -Wextra \
-Wold-style-definition -Wdeclaration-after-statement \
-Wmissing-declarations -Werror-implicit-function-declaration \
@@ -17,7 +19,7 @@ MAYBE_WARN="-Wall -Wextra \
-Wbad-function-cast -Wvolatile-register-var \
-Wstrict-aliasing=2 -Winit-self -Wunsafe-loop-optimizations \
-Wno-missing-field-initializers -Wno-unused-parameter \
--Wno-attributes -Wno-long-long -Winline -Wlogical-op"
+-Wno-attributes -Wno-long-long -Winline"
dnl Sun Studio 12 likes to rag at us for abusing enums like
dnl having cairo_status_t variables hold cairo_int_status_t