summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorLoïc Minier <lool@dooz.org>2009-04-14 23:42:19 +0200
committerLoïc Minier <lool@dooz.org>2009-04-14 23:42:19 +0200
commit57e531b852e2fc3fd9c82fe0617dd34075703f13 (patch)
tree535b1d3ecc71829e7bb4a7f89ba56f2bc99f98f5 /Makefile.in
parent966f990f0b25352fd4f9c7f9beb844c5d94f9408 (diff)
Imported Upstream version 1.2.4
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in130
1 files changed, 103 insertions, 27 deletions
diff --git a/Makefile.in b/Makefile.in
index a393cfd..26e3d2b 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -13,6 +13,13 @@
# PARTICULAR PURPOSE.
@SET_MAKE@
+
+# Creating ChangeLog files from git log:
+
+# We always create a ChangeLog that contains the most recent changes, and
+# multiple others for changes between major releases (other than the last such
+# segment that we put in 'ChangeLog'. The old ones are named
+# ChangeLog.pre-X.Y where X.Y is the version number of the major release.
srcdir = @srcdir@
top_srcdir = @top_srcdir@
VPATH = @srcdir@
@@ -38,11 +45,11 @@ host_triplet = @host@
# libpng is required for our test programs
@CAIRO_HAS_PNG_FUNCTIONS_TRUE@am__append_1 = test
-DIST_COMMON = README $(am__configure_deps) $(srcdir)/Makefile.am \
- $(srcdir)/Makefile.in $(srcdir)/config.h.in \
- $(top_srcdir)/configure AUTHORS COPYING ChangeLog INSTALL NEWS \
- TODO compile config.guess config.sub depcomp install-sh \
- ltmain.sh missing
+DIST_COMMON = README $(am__configure_deps) $(srcdir)/ChangeLog.mk \
+ $(srcdir)/Makefile.am $(srcdir)/Makefile.in \
+ $(srcdir)/config.h.in $(top_srcdir)/configure AUTHORS COPYING \
+ ChangeLog INSTALL NEWS TODO compile config.guess config.sub \
+ depcomp install-sh ltmain.sh missing
subdir = .
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
am__aclocal_m4_deps = $(top_srcdir)/acinclude.m4 \
@@ -271,6 +278,7 @@ oldincludedir = @oldincludedir@
pdfdir = @pdfdir@
png_CFLAGS = @png_CFLAGS@
png_LIBS = @png_LIBS@
+png_REQUIRES = @png_REQUIRES@
prefix = @prefix@
program_transform_name = @program_transform_name@
psdir = @psdir@
@@ -280,27 +288,53 @@ sysconfdir = @sysconfdir@
target_alias = @target_alias@
xcb_CFLAGS = @xcb_CFLAGS@
xcb_LIBS = @xcb_LIBS@
+xlib_CFLAGS = @xlib_CFLAGS@
+xlib_LIBS = @xlib_LIBS@
xlib_xrender_CFLAGS = @xlib_xrender_CFLAGS@
xlib_xrender_LIBS = @xlib_xrender_LIBS@
DIST_SUBDIRS = pixman src test doc
SUBDIRS = pixman src doc $(am__append_1)
-EXTRA_DIST = COPYING COPYING-LGPL-2.1 COPYING-MPL-1.1 ChangeLog
-DISTCLEANFILES = config.cache
-
-# Creating ChangeLog from git log:
+EXTRA_DIST = \
+ BUGS \
+ CODING_STYLE \
+ COPYING \
+ COPYING-LGPL-2.1 \
+ COPYING-MPL-1.1 \
+ PORTING_GUIDE \
+ RELEASING \
+ ROADMAP \
+ TODO
+
+DISTCLEANFILES = config.cache $(srcdir)/ChangeLog.cache-*
MAINTAINERCLEANFILES = $(srcdir)/aclocal.m4 $(srcdir)/autoscan.log \
$(srcdir)/compile $(srcdir)/config.guess $(srcdir)/config.h.in \
$(srcdir)/config.sub $(srcdir)/configure.scan \
$(srcdir)/depcomp $(srcdir)/install-sh $(srcdir)/ltmain.sh \
$(srcdir)/missing $(srcdir)/mkinstalldirs `find "$(srcdir)" \
- -type f -name Makefile.in -print` ChangeLog
+ -type f -name Makefile.in -print` $(srcdir)/ChangeLog \
+ $(srcdir)/ChangeLog.pre-*
DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc
+CURR_CHANGELOG_VERSION = $(CAIRO_VERSION_MAJOR).$$(echo "($(CAIRO_VERSION_MINOR)+1)/2*2" | bc)
+# examines $version
+PREV_CHANGELOG_VERSION = $$(if test "x$$(echo "($$version-0.1)*2/2"|bc)" = "x$$(echo "$$version*2/2"|bc)"; \
+ then echo "$$version-$$(echo "$$version" | sed 's/[0-9]/0/g;s/[0-9]$$/2/')"; \
+ else echo "$$version-1.0"; \
+ fi | bc | sed 's/[.]0*/./;s/^0[.]\?$$/initial/;s/[.]$$/.0/')
+
+CHANGELOGS = ChangeLog \
+ `version=$(CURR_CHANGELOG_VERSION); \
+ version=$(PREV_CHANGELOG_VERSION); \
+ while test "x$$version" != xinitial; do \
+ echo ChangeLog.pre-$$version; \
+ version=$(PREV_CHANGELOG_VERSION); \
+ done`
+
# Some custom targets to make it easier to release things.
# Use either:
# make release-check
# or make release-publish
-RELEASE_OR_SNAPSHOT = `if [ "$(CAIRO_VERSION_MINOR)" = $$(echo "$(CAIRO_VERSION_MINOR)/2*2" | bc) ]; then echo release; else echo snapshot; fi`
+RELEASE_OR_SNAPSHOT = $$(if test "x$(CAIRO_VERSION_MINOR)" = "x$$(echo "$(CAIRO_VERSION_MINOR)/2*2" | bc)" ; then echo release; else echo snapshot; fi)
RELEASE_UPLOAD_HOST = cairographics.org
RELEASE_UPLOAD_BASE = /srv/cairo.freedesktop.org/www
RELEASE_UPLOAD_DIR = $(RELEASE_UPLOAD_BASE)/$(RELEASE_OR_SNAPSHOT)s
@@ -322,7 +356,7 @@ all: config.h
.SUFFIXES:
am--refresh:
@:
-$(srcdir)/Makefile.in: @MAINTAINER_MODE_TRUE@ $(srcdir)/Makefile.am $(am__configure_deps)
+$(srcdir)/Makefile.in: @MAINTAINER_MODE_TRUE@ $(srcdir)/Makefile.am $(srcdir)/ChangeLog.mk $(am__configure_deps)
@for dep in $?; do \
case '$(am__configure_deps)' in \
*$$dep*) \
@@ -558,6 +592,9 @@ distdir: $(DISTFILES)
|| exit 1; \
fi; \
done
+ $(MAKE) $(AM_MAKEFLAGS) \
+ top_distdir="$(top_distdir)" distdir="$(distdir)" \
+ dist-hook
-find $(distdir) -type d ! -perm -777 -exec chmod a+rwx {} \; -o \
! -type d ! -perm -444 -links 1 -exec chmod a+r {} \; -o \
! -type d ! -perm -400 -exec chmod a+r {} \; -o \
@@ -741,7 +778,7 @@ uninstall-info: uninstall-info-recursive
.PHONY: $(RECURSIVE_TARGETS) CTAGS GTAGS all all-am am--refresh check \
check-am clean clean-generic clean-libtool clean-recursive \
ctags ctags-recursive dist dist-all dist-bzip2 dist-gzip \
- dist-shar dist-tarZ dist-zip distcheck distclean \
+ dist-hook dist-shar dist-tarZ dist-zip distcheck distclean \
distclean-generic distclean-hdr distclean-libtool \
distclean-recursive distclean-tags distcleancheck distdir \
distuninstallcheck dvi dvi-am html html-am info info-am \
@@ -754,36 +791,75 @@ uninstall-info: uninstall-info-recursive
tags tags-recursive uninstall uninstall-am uninstall-info-am
-.PHONY: doc test
+.PHONY: doc test retest recheck check-valgrind
doc:
- -$(MAKE) -C doc doc
+ cd doc && $(MAKE) $(AM_MAKEFLAGS) doc
test: all
- -$(MAKE) -C test test
+ cd test && $(MAKE) $(AM_MAKEFLAGS) test
retest: all
- -$(MAKE) -C test retest
+ cd test && $(MAKE) $(AM_MAKEFLAGS) retest
recheck: all
- -$(MAKE) -C test recheck
-
+ cd test && $(MAKE) $(AM_MAKEFLAGS) recheck
check-valgrind: all
- $(MAKE) -C test check-valgrind
+ cd test && $(MAKE) $(AM_MAKEFLAGS) check-valgrind
+
+changelogs:
+ @$(MAKE) $(AM_MAKEFLAGS) $(CHANGELOGS)
-ChangeLog: $(srcdir)/ChangeLog
+dist-hook: changelogs
+ changelogs="$(CHANGELOGS)"; \
+ for changelog in $$changelogs; do \
+ cp $(srcdir)/$$changelog $(distdir)/ 2>/dev/null || \
+ cp $$changelog $(distdir)/; \
+ done
$(srcdir)/ChangeLog:
@if test -d "$(srcdir)/.git"; then \
+ version=$(CURR_CHANGELOG_VERSION); \
+ prev=$(PREV_CHANGELOG_VERSION).0; \
+ nearest_tag=`git-describe | sed 's/-[^-]*//'`; \
+ before=$(srcdir)/ChangeLog.cache-$$prev..$$nearest_tag; \
+ after=$(srcdir)/ChangeLog.cache-$$nearest_tag..; \
+ $(MAKE) $(AM_MAKEFLAGS) $$before $$after && \
+ echo Creating $@ && \
+ { cat $$after; echo; cat $$before; } > $@; \
+ else \
+ test -f $@ || \
+ (echo A git checkout is required to generate $@ >&2 && \
+ echo A git checkout is required to generate this file >> $@); \
+ fi
+
+ChangeLog.cache-*..: .git
+
+ChangeLog%: $(srcdir)/ChangeLog%
+
+$(srcdir)/ChangeLog.cache-% $(srcdir)/ChangeLog.pre-%:
+ @echo Creating $@
+ @if test -d "$(srcdir)/.git"; then \
(cd "$(srcdir)" && \
- ./missing --run git-log --stat) | fmt --split-only > $@.tmp \
+ version=$$(echo "$@" | sed 's/.*ChangeLog\([.].*-\)\?//'); \
+ if echo "$@" | grep -q '^ChangeLog[.]cache'; then \
+ spec=$$version; \
+ else \
+ to=$$version; \
+ test "x$$version" = x && version=$(CURR_CHANGELOG_VERSION); \
+ from=$(PREV_CHANGELOG_VERSION); \
+ test "x$$to" = x || version=$$version.0; \
+ test "x$$from" = xinitial || from=$$from.0; \
+ spec=$$from..$$to; \
+ fi; \
+ ./missing --run git-log --stat "$$spec") > $@.tmp \
&& mv -f $@.tmp $@ \
|| ($(RM) $@.tmp; \
- echo Failed to generate ChangeLog, your ChangeLog may be outdated >&2; \
+ echo Failed to generate $@, your $@ may be outdated >&2; \
(test -f $@ || echo git-log is required to generate this file >> $@)); \
else \
test -f $@ || \
- (echo A git checkout and git-log is required to generate ChangeLog >&2 && \
- echo A git checkout and git-log is required to generate this file >> $@); \
+ (echo A git checkout is required to generate $@ >&2 && \
+ echo A git checkout is required to generate this file >> $@); \
fi
-.PHONY: ChangeLog $(srcdir)/ChangeLog
+.PHONY: changelogs ChangeLog $(srcdir)/ChangeLog
$(sha1_file): $(tar_file)
sha1sum $^ > $@
@@ -903,7 +979,7 @@ docs-publish: all
scp $(MANUAL_TAR_FILE) $(RELEASE_UPLOAD_HOST):$(MANUAL_UPLOAD_DIR)
ssh $(RELEASE_UPLOAD_HOST) "cd $(MANUAL_UPLOAD_DIR) && tar xzf $(MANUAL_TAR_FILE) && rm -f manual && ln -s $(MANUAL_DATED) manual && ln -sf $(MANUAL_TAR_FILE) cairo-manual.tar.gz"
-.PHONY: release-verify-even-micro release-verify-newer release-remove-old release-cleanup-group-sticky release-check release-upload release-publish docs-publish test retest recheck
+.PHONY: release-verify-even-micro release-verify-newer release-remove-old release-cleanup-group-sticky release-check release-upload release-publish docs-publish
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.
.NOEXPORT: