summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLoïc Minier <lool@dooz.org>2009-04-14 23:51:49 +0200
committerLoïc Minier <lool@dooz.org>2009-04-14 23:51:49 +0200
commitc3a6ad2f359581218096644b68e17d5b56986d40 (patch)
tree7b22175aa640aa449b06fb1918ee4a16f5ec6842 /Makefile.am
parent1817553f7a148d81fec0eb41fb6c59709b1d02f9 (diff)
Imported Upstream version 1.4.6
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 13 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 23166ea..4410c02 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,8 +1,8 @@
-DIST_SUBDIRS = pixman src boilerplate test perf doc
+DIST_SUBDIRS = pixman src boilerplate test perf doc util
SUBDIRS = pixman src doc
# libpng is required for our test programs
if CAIRO_HAS_PNG_FUNCTIONS
-SUBDIRS += boilerplate test
+SUBDIRS += boilerplate test perf
endif
@@ -19,6 +19,7 @@ recheck: all
cd test && $(MAKE) $(AM_MAKEFLAGS) recheck
check-valgrind: all
cd test && $(MAKE) $(AM_MAKEFLAGS) check-valgrind
+ cd perf && $(MAKE) $(AM_MAKEFLAGS) check-valgrind
perf: all
cd perf && $(MAKE) $(AM_MAKEFLAGS) perf
lcov: check
@@ -69,9 +70,18 @@ DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc --enable-test-surfaces
include $(srcdir)/ChangeLog.mk
# Some custom targets to make it easier to release things.
-# Use either:
+#
+# To make real stable releases or devel snapshots, use either:
# make release-check
# or make release-publish
+#
+# To make a quick properly named (date and git hash stamped) tarball:
+# make snapshot
+
+snapshot:
+ distdir="$(distdir)-`date '+%Y%m%d'`"; \
+ test -d "$(srcdir)/.git" && distdir=$$distdir-`cd "$(srcdir)" && git-rev-parse HEAD | cut -c 1-6`; \
+ $(MAKE) $(AM_MAKEFLAGS) distdir="$$distdir" dist
RELEASE_OR_SNAPSHOT = $$(if test "x$(CAIRO_VERSION_MINOR)" = "x$$(echo "$(CAIRO_VERSION_MINOR)/2*2" | bc)" ; then echo release; else echo snapshot; fi)
RELEASE_UPLOAD_HOST = cairographics.org