summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Dröge <sebastian.droege@collabora.co.uk>2011-01-19 12:19:05 +0100
committerSebastian Dröge <sebastian.droege@collabora.co.uk>2011-01-19 12:19:05 +0100
commitedfbb135bcf94c655d3df8054dc4b49e0b6fc005 (patch)
tree99556bc9c5e19e2e371770d861cef25249480165
parent210321dd61dff44c81d4e480ac837088a8b9e473 (diff)
Revert some unwanted changes from last commit
-rw-r--r--build/configure.ac.features1
-rw-r--r--configure.ac6
-rw-r--r--perf/Makefile.am12
3 files changed, 0 insertions, 19 deletions
diff --git a/build/configure.ac.features b/build/configure.ac.features
index a80d466..dc3c8b8 100644
--- a/build/configure.ac.features
+++ b/build/configure.ac.features
@@ -407,7 +407,6 @@ AC_DEFUN([CAIRO_REPORT],
echo "The following features and utilities:"
echo " cairo-trace: $use_trace"
echo " cairo-script-interpreter: $use_interpreter"
- echo " cairo-perf-utils: $use_perf_utils"
echo ""
echo "And the following internal features:"
echo " pthread: $use_pthread"
diff --git a/configure.ac b/configure.ac
index ef5017d..1238f5e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10,7 +10,6 @@ AC_USE_SYSTEM_EXTENSIONS
AC_CONFIG_SRCDIR(src/cairo.h)
AC_CONFIG_HEADERS(config.h)
AM_INIT_AUTOMAKE([1.9.6 gnu -Wall no-define])
-AM_MAINTAINER_MODE
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
AC_LIBTOOL_WIN32_DLL dnl Must be called before AC_PROG_LIBTOOL
AC_PROG_LIBTOOL dnl ([1.4]) Don't remove!
@@ -797,11 +796,6 @@ dnl ===========================================================================
PKG_CHECK_MODULES(gtk, "gtk+-2.0",have_gtk=yes, have_gtk=no)
AM_CONDITIONAL(HAVE_GTK, test "x$have_gtk" = "xyes")
-dnl ===========================================================================
-
-CAIRO_ENABLE(perf_utils, cairo-perf-utils, no, [use_perf_utils=yes])
-
-
AC_CONFIG_FILES([
Makefile
boilerplate/Makefile
diff --git a/perf/Makefile.am b/perf/Makefile.am
index f64444f..6a1b72c 100644
--- a/perf/Makefile.am
+++ b/perf/Makefile.am
@@ -10,18 +10,6 @@ AM_CPPFLAGS = \
AM_LDFLAGS = $(CAIRO_LDFLAGS)
-if CAIRO_HAS_PERF_UTILS
-bin_PROGRAMS = cairo-perf-micro \
- cairo-perf-trace \
- cairo-perf-diff-files \
- cairo-perf-print \
- cairo-perf-chart \
- cairo-perf-compare-backends
-if HAVE_GTK
-bin_PROGRAMS += cairo-perf-graph-files
-endif
-endif
-
EXTRA_PROGRAMS += cairo-perf-micro \
cairo-perf-trace \
cairo-perf-diff-files \