summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Dröge <sebastian.droege@collabora.co.uk>2011-02-08 09:55:27 +0100
committerSebastian Dröge <sebastian.droege@collabora.co.uk>2011-02-08 09:55:27 +0100
commite4716cc16ea8b4e540bb6e4d4120648c3fdbed66 (patch)
treee15a8b118651d904cbd4c894ba53dcb0e026399a
parentffa2862d1de43ddfed1bc0b2233eceab6af882c7 (diff)
debian/libcairo2.symbols, debian/rules:
* debian/libcairo2.symbols, debian/rules: + Update shlibs and symbols files.
-rw-r--r--build/configure.ac.features1
-rw-r--r--configure.ac6
-rw-r--r--debian/changelog5
-rw-r--r--debian/libcairo2.symbols15
-rwxr-xr-xdebian/rules2
-rw-r--r--perf/Makefile.am12
6 files changed, 39 insertions, 2 deletions
diff --git a/build/configure.ac.features b/build/configure.ac.features
index dc3c8b8..a80d466 100644
--- a/build/configure.ac.features
+++ b/build/configure.ac.features
@@ -407,6 +407,7 @@ AC_DEFUN([CAIRO_REPORT],
echo "The following features and utilities:"
echo " cairo-trace: $use_trace"
echo " cairo-script-interpreter: $use_interpreter"
+ echo " cairo-perf-utils: $use_perf_utils"
echo ""
echo "And the following internal features:"
echo " pthread: $use_pthread"
diff --git a/configure.ac b/configure.ac
index 1238f5e..ef5017d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10,6 +10,7 @@ AC_USE_SYSTEM_EXTENSIONS
AC_CONFIG_SRCDIR(src/cairo.h)
AC_CONFIG_HEADERS(config.h)
AM_INIT_AUTOMAKE([1.9.6 gnu -Wall no-define])
+AM_MAINTAINER_MODE
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
AC_LIBTOOL_WIN32_DLL dnl Must be called before AC_PROG_LIBTOOL
AC_PROG_LIBTOOL dnl ([1.4]) Don't remove!
@@ -796,6 +797,11 @@ dnl ===========================================================================
PKG_CHECK_MODULES(gtk, "gtk+-2.0",have_gtk=yes, have_gtk=no)
AM_CONDITIONAL(HAVE_GTK, test "x$have_gtk" = "xyes")
+dnl ===========================================================================
+
+CAIRO_ENABLE(perf_utils, cairo-perf-utils, no, [use_perf_utils=yes])
+
+
AC_CONFIG_FILES([
Makefile
boilerplate/Makefile
diff --git a/debian/changelog b/debian/changelog
index 83fb427..f5bcc9a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -9,8 +9,11 @@ cairo (1.10.2-2) unstable; urgency=low
* debian/control,
debian/rules:
+ Enable the OpenGL/EGL backend (Closes: #611692).
+ * debian/libcairo2.symbols,
+ debian/rules:
+ + Update shlibs and symbols files.
- -- Sebastian Dröge <slomo@debian.org> Tue, 08 Feb 2011 09:42:30 +0100
+ -- Sebastian Dröge <slomo@debian.org> Tue, 08 Feb 2011 09:54:30 +0100
cairo (1.10.2-1) experimental; urgency=low
diff --git a/debian/libcairo2.symbols b/debian/libcairo2.symbols
index fb28e51..1f5cd42 100644
--- a/debian/libcairo2.symbols
+++ b/debian/libcairo2.symbols
@@ -81,6 +81,17 @@ libcairo.so.2 libcairo2 #MINVER#
cairo_get_target@Base 1.2.4
cairo_get_tolerance@Base 1.2.4
cairo_get_user_data@Base 1.4.10
+ cairo_gl_surface_create@Base 1.10.2-2~
+ cairo_gl_surface_create_for_egl@Base 1.10.2-2~
+ cairo_gl_surface_create_for_texture@Base 1.10.2-2~
+ cairo_gl_surface_create_for_window@Base 1.10.2-2~
+ cairo_gl_surface_get_height@Base 1.10.2-2~
+ cairo_gl_surface_get_width@Base 1.10.2-2~
+ cairo_gl_surface_set_size@Base 1.10.2-2~
+ cairo_gl_surface_swapbuffers@Base 1.10.2-2~
+ cairo_glx_device_create@Base 1.10.2-2~
+ cairo_glx_device_get_context@Base 1.10.2-2~
+ cairo_glx_device_get_display@Base 1.10.2-2~
cairo_glyph_allocate@Base 1.7.2
cairo_glyph_extents@Base 1.2.4
cairo_glyph_free@Base 1.7.2
@@ -283,6 +294,10 @@ libcairo.so.2 libcairo2 #MINVER#
cairo_svg_surface_create_for_stream@Base 1.2.4
cairo_svg_surface_restrict_to_version@Base 1.2.4
cairo_svg_version_to_string@Base 1.2.4
+ cairo_tee_surface_add@Base 1.10.2-2~
+ cairo_tee_surface_create@Base 1.10.2-2~
+ cairo_tee_surface_index@Base 1.10.2-2~
+ cairo_tee_surface_remove@Base 1.10.2-2~
cairo_text_cluster_allocate@Base 1.7.2
cairo_text_cluster_free@Base 1.7.2
cairo_text_extents@Base 1.2.4
diff --git a/debian/rules b/debian/rules
index b7b0d1c..fe8bc01 100755
--- a/debian/rules
+++ b/debian/rules
@@ -157,7 +157,7 @@ binary-arch: build install
dh_strip -plibcairo2-udeb
dh_compress -s
dh_fixperms -s
- dh_makeshlibs -plibcairo2 --add-udeb=libcairo2-udeb -V 'libcairo2 (>= 1.10.0)' -- -c4
+ dh_makeshlibs -plibcairo2 --add-udeb=libcairo2-udeb -V 'libcairo2 (>= 1.10.2-2~)' -- -c4
dh_makeshlibs -plibcairo-gobject2 -V 'libcairo-gobject2 (>= 1.10.0)' -- -c4
dh_makeshlibs -plibcairo-script-interpreter2 -V 'libcairo-script-interpreter2 (>= 1.10.0)' -- -c4
dh_installdeb -s
diff --git a/perf/Makefile.am b/perf/Makefile.am
index 6a1b72c..f64444f 100644
--- a/perf/Makefile.am
+++ b/perf/Makefile.am
@@ -10,6 +10,18 @@ AM_CPPFLAGS = \
AM_LDFLAGS = $(CAIRO_LDFLAGS)
+if CAIRO_HAS_PERF_UTILS
+bin_PROGRAMS = cairo-perf-micro \
+ cairo-perf-trace \
+ cairo-perf-diff-files \
+ cairo-perf-print \
+ cairo-perf-chart \
+ cairo-perf-compare-backends
+if HAVE_GTK
+bin_PROGRAMS += cairo-perf-graph-files
+endif
+endif
+
EXTRA_PROGRAMS += cairo-perf-micro \
cairo-perf-trace \
cairo-perf-diff-files \