summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Dröge <sebastian.droege@collabora.co.uk>2010-09-10 10:51:13 +0200
committerSebastian Dröge <sebastian.droege@collabora.co.uk>2010-09-10 10:51:13 +0200
commitc7b321cfebddeb490a8b2d0cfa1d4eb43f3c40b1 (patch)
tree80c5ef85d0b54e8623347691d706b709dcac212e
parent7e2e370bbfc1ea9a8b501d9877cfc52bdc6f2841 (diff)
debian/patches/02_iceweasel-buggy-repeat.patch:
* debian/patches/02_iceweasel-buggy-repeat.patch: + Revert logic of the patch for the infamous iceweasel rendering problems. The only broken X11 driver that is left seems to be fglrx and always enabling the workaround code in cairo causes severe performance degradations for everybody (Closes: #594245). Thanks for Josselin Mouette for the patch. Everybody using the fglrx driver should set the MOZ_CAIRO_BUGGY_REPEAT environment variable, everybody else should get a correctly working and fast cairo again.
-rw-r--r--debian/changelog14
-rw-r--r--debian/patches/02_iceweasel-buggy-repeat.patch6
2 files changed, 17 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 8e040c3..ee74873 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,17 @@
+cairo (1.8.10-6) unstable; urgency=low
+
+ * debian/patches/02_iceweasel-buggy-repeat.patch:
+ + Revert logic of the patch for the infamous iceweasel rendering
+ problems. The only broken X11 driver that is left seems to be
+ fglrx and always enabling the workaround code in cairo causes
+ severe performance degradations for everybody (Closes: #594245).
+ Thanks for Josselin Mouette for the patch.
+ Everybody using the fglrx driver should set the MOZ_CAIRO_BUGGY_REPEAT
+ environment variable, everybody else should get a correctly working
+ and fast cairo again.
+
+ -- Sebastian Dröge <slomo@debian.org> Fri, 10 Sep 2010 10:48:34 +0200
+
cairo (1.8.10-5) unstable; urgency=low
* debian/patches/02_iceweasel-buggy-repeat.patch:
diff --git a/debian/patches/02_iceweasel-buggy-repeat.patch b/debian/patches/02_iceweasel-buggy-repeat.patch
index b5fc80b..5269b81 100644
--- a/debian/patches/02_iceweasel-buggy-repeat.patch
+++ b/debian/patches/02_iceweasel-buggy-repeat.patch
@@ -17,10 +17,10 @@ Index: cairo/src/cairo-xlib-display.c
+ /* XXX workaround; see https://bugzilla.mozilla.org/show_bug.cgi?id=413583 */
+ if (buggy_repeat_force == -1) {
-+ if (getenv("MOZ_CAIRO_NO_BUGGY_REPEAT"))
-+ buggy_repeat_force = 0;
-+ else
++ if (getenv("MOZ_CAIRO_BUGGY_REPEAT"))
+ buggy_repeat_force = 1;
++ else
++ buggy_repeat_force = 0;
+ }
+
+ if (buggy_repeat_force)