summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Dröge <sebastian.droege@collabora.co.uk>2010-08-17 05:51:25 +0200
committerSebastian Dröge <sebastian.droege@collabora.co.uk>2010-08-17 05:51:25 +0200
commit93369d1db84cb98e227b885c0f21125033365969 (patch)
tree1f5a1bd59b7f8677a37d4080a7d9242cf22c8ddc
parent581fb6e86ffd5295f5174f56135fd74bd4c875f0 (diff)
debian/patches/02_iceweasel-buggy-repeat.patch:
* debian/patches/02_iceweasel-buggy-repeat.patch: + Patch from Mozilla to work around a display bug in iceweasel with some buggy X11 video drivers (Closes: #495620). http://mxr.mozilla.org/firefox/source/gfx/cairo/buggy-repeat.patch After squeeze this patch will again be dropped because it's just a hacky workaround for a real problem in some X11 video drivers.
-rw-r--r--debian/changelog13
-rw-r--r--debian/patches/02_iceweasel-buggy-repeat.patch30
-rw-r--r--debian/patches/series1
3 files changed, 44 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 0902477..b17dcba 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,16 @@
+cairo (1.8.10-5) unstable; urgency=low
+
+ * debian/patches/02_iceweasel-buggy-repeat.patch:
+ + Patch from Mozilla to work around a display bug in iceweasel with
+ some buggy X11 video drivers (Closes: #495620).
+ http://mxr.mozilla.org/firefox/source/gfx/cairo/buggy-repeat.patch
+
+ After squeeze this patch will again be dropped because it's
+ just a hacky workaround for a real problem in some X11 video
+ drivers.
+
+ -- Sebastian Dröge <slomo@debian.org> Tue, 17 Aug 2010 05:48:52 +0200
+
cairo (1.8.10-4) unstable; urgency=low
* debian/rules:
diff --git a/debian/patches/02_iceweasel-buggy-repeat.patch b/debian/patches/02_iceweasel-buggy-repeat.patch
new file mode 100644
index 0000000..84af42e
--- /dev/null
+++ b/debian/patches/02_iceweasel-buggy-repeat.patch
@@ -0,0 +1,30 @@
+diff --git a/gfx/cairo/cairo/src/cairo-xlib-display.c b/gfx/cairo/cairo/src/cairo-xlib-display.c
+--- cairo/src/cairo-xlib-display.c
++++ cairo/src/cairo-xlib-display.c
+@@ -63,6 +63,8 @@ struct _cairo_xlib_job {
+ };
+
+ static cairo_xlib_display_t *_cairo_xlib_display_list;
++
++static int buggy_repeat_force = -1;
+
+ static void
+ _cairo_xlib_call_close_display_hooks (cairo_xlib_display_t *display)
+@@ -302,6 +304,17 @@ _cairo_xlib_display_get (Display *dpy)
+ display->buggy_repeat = TRUE;
+ }
+
++ /* XXX workaround; see https://bugzilla.mozilla.org/show_bug.cgi?id=413583 */
++ if (buggy_repeat_force == -1) {
++ if (getenv("MOZ_CAIRO_NO_BUGGY_REPEAT"))
++ buggy_repeat_force = 0;
++ else
++ buggy_repeat_force = 1;
++ }
++
++ if (buggy_repeat_force)
++ display->buggy_repeat = TRUE;
++
+ display->next = _cairo_xlib_display_list;
+ _cairo_xlib_display_list = display;
+
diff --git a/debian/patches/series b/debian/patches/series
index 9485454..80cef15 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,2 +1,3 @@
01_no-private-symbol-export.patch
+02_iceweasel-buggy-repeat.patch
99_ltmain_as-needed.patch