summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Dröge <sebastian.droege@collabora.co.uk>2011-02-08 10:13:25 +0100
committerSebastian Dröge <sebastian.droege@collabora.co.uk>2011-02-08 10:13:25 +0100
commit555e105e521f5232e6cf2ace5d380a5cb58a37db (patch)
treeef5f0b805abde91e35c3d77e5be3fd3aba13a3f1
parente4716cc16ea8b4e540bb6e4d4120648c3fdbed66 (diff)
debian/patches/03_export-symbols.patch:
* debian/patches/03_export-symbols.patch: + Only export public cairo symbols.
-rw-r--r--debian/changelog2
-rw-r--r--debian/libcairo2.symbols1
-rw-r--r--debian/patches/03_export-symbols.patch13
-rw-r--r--debian/patches/series1
-rw-r--r--src/Makefile.am2
5 files changed, 18 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index f5bcc9a..9c925d4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -12,6 +12,8 @@ cairo (1.10.2-2) unstable; urgency=low
* debian/libcairo2.symbols,
debian/rules:
+ Update shlibs and symbols files.
+ * debian/patches/03_export-symbols.patch:
+ + Only export public cairo symbols.
-- Sebastian Dröge <slomo@debian.org> Tue, 08 Feb 2011 09:54:30 +0100
diff --git a/debian/libcairo2.symbols b/debian/libcairo2.symbols
index 1f5cd42..5f7dd45 100644
--- a/debian/libcairo2.symbols
+++ b/debian/libcairo2.symbols
@@ -28,6 +28,7 @@ libcairo.so.2 libcairo2 #MINVER#
cairo_device_status@Base 1.10.0
cairo_device_to_user@Base 1.2.4
cairo_device_to_user_distance@Base 1.2.4
+ cairo_egl_device_create@Base 1.10.2-2~
cairo_fill@Base 1.2.4
cairo_fill_extents@Base 1.2.4
cairo_fill_preserve@Base 1.2.4
diff --git a/debian/patches/03_export-symbols.patch b/debian/patches/03_export-symbols.patch
new file mode 100644
index 0000000..21fe9cd
--- /dev/null
+++ b/debian/patches/03_export-symbols.patch
@@ -0,0 +1,13 @@
+Index: cairo/src/Makefile.am
+===================================================================
+--- cairo.orig/src/Makefile.am 2011-02-08 10:11:46.879538772 +0100
++++ cairo/src/Makefile.am 2011-02-08 10:12:36.381915666 +0100
+@@ -46,7 +46,7 @@
+ $(enabled_cairo_private) \
+ $(enabled_cairo_sources) \
+ $(NULL)
+-libcairo_la_LDFLAGS = $(AM_LDFLAGS) -version-info $(CAIRO_LIBTOOL_VERSION_INFO) -no-undefined $(export_symbols)
++libcairo_la_LDFLAGS = $(AM_LDFLAGS) -version-info $(CAIRO_LIBTOOL_VERSION_INFO) -no-undefined $(export_symbols) -export-symbols-regex \^cairo_.*
+ libcairo_la_LIBADD = $(CAIRO_LIBS) \
+ $(cairo_cxx_lib)
+ libcairo_la_DEPENDENCIES = $(cairo_def_dependency) $(cairo_cxx_lib)
diff --git a/debian/patches/series b/debian/patches/series
index 8606a57..7290263 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,2 +1,3 @@
01_build_perf_utils.patch
02_am-maintainer-mode.patch
+03_export-symbols.patch
diff --git a/src/Makefile.am b/src/Makefile.am
index 5edf706..eb77e44 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -46,7 +46,7 @@ libcairo_la_SOURCES = \
$(enabled_cairo_private) \
$(enabled_cairo_sources) \
$(NULL)
-libcairo_la_LDFLAGS = $(AM_LDFLAGS) -version-info $(CAIRO_LIBTOOL_VERSION_INFO) -no-undefined $(export_symbols)
+libcairo_la_LDFLAGS = $(AM_LDFLAGS) -version-info $(CAIRO_LIBTOOL_VERSION_INFO) -no-undefined $(export_symbols) -export-symbols-regex \^cairo_.*
libcairo_la_LIBADD = $(CAIRO_LIBS) \
$(cairo_cxx_lib)
libcairo_la_DEPENDENCIES = $(cairo_def_dependency) $(cairo_cxx_lib)