summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Dröge <sebastian.droege@collabora.co.uk>2011-01-19 12:14:36 +0100
committerSebastian Dröge <sebastian.droege@collabora.co.uk>2011-01-19 12:14:36 +0100
commit210321dd61dff44c81d4e480ac837088a8b9e473 (patch)
treece120d3721563e860c79a4cbc1f74641939337fa
parenta1f0ada7a95eee3b2e21a9d8d76453626674311c (diff)
debian/control:
* debian/control: + Let libcairo2-dev depend on libcairo-script-interpreter2 to prevent dangling symlinks.
-rw-r--r--build/configure.ac.features1
-rw-r--r--configure.ac6
-rw-r--r--debian/changelog8
-rw-r--r--debian/control4
-rw-r--r--perf/Makefile.am12
5 files changed, 29 insertions, 2 deletions
diff --git a/build/configure.ac.features b/build/configure.ac.features
index dc3c8b8..a80d466 100644
--- a/build/configure.ac.features
+++ b/build/configure.ac.features
@@ -407,6 +407,7 @@ AC_DEFUN([CAIRO_REPORT],
echo "The following features and utilities:"
echo " cairo-trace: $use_trace"
echo " cairo-script-interpreter: $use_interpreter"
+ echo " cairo-perf-utils: $use_perf_utils"
echo ""
echo "And the following internal features:"
echo " pthread: $use_pthread"
diff --git a/configure.ac b/configure.ac
index 1238f5e..ef5017d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10,6 +10,7 @@ AC_USE_SYSTEM_EXTENSIONS
AC_CONFIG_SRCDIR(src/cairo.h)
AC_CONFIG_HEADERS(config.h)
AM_INIT_AUTOMAKE([1.9.6 gnu -Wall no-define])
+AM_MAINTAINER_MODE
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
AC_LIBTOOL_WIN32_DLL dnl Must be called before AC_PROG_LIBTOOL
AC_PROG_LIBTOOL dnl ([1.4]) Don't remove!
@@ -796,6 +797,11 @@ dnl ===========================================================================
PKG_CHECK_MODULES(gtk, "gtk+-2.0",have_gtk=yes, have_gtk=no)
AM_CONDITIONAL(HAVE_GTK, test "x$have_gtk" = "xyes")
+dnl ===========================================================================
+
+CAIRO_ENABLE(perf_utils, cairo-perf-utils, no, [use_perf_utils=yes])
+
+
AC_CONFIG_FILES([
Makefile
boilerplate/Makefile
diff --git a/debian/changelog b/debian/changelog
index bedad47..3423f6b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+cairo (1.10.2-2) UNRELEASED; urgency=low
+
+ * debian/control:
+ + Let libcairo2-dev depend on libcairo-script-interpreter2 to
+ prevent dangling symlinks.
+
+ -- Sebastian Dröge <slomo@debian.org> Wed, 19 Jan 2011 12:13:26 +0100
+
cairo (1.10.2-1) experimental; urgency=low
* New upstream bugfix release:
diff --git a/debian/control b/debian/control
index c6a7f56..0ef33e7 100644
--- a/debian/control
+++ b/debian/control
@@ -31,6 +31,7 @@ Section: libdevel
Architecture: any
Depends: libcairo2 (= ${binary:Version}),
libcairo-gobject2 (= ${binary:Version}),
+ libcairo-script-interpreter2 (= ${binary:Version}),
libfontconfig1-dev (>= 2.2.95),
libfreetype6-dev (>= 2.1.10),
libx11-dev,
@@ -45,8 +46,7 @@ Depends: libcairo2 (= ${binary:Version}),
${shlibs:Depends},
${misc:Depends}
Provides: libcairo-dev
-Suggests: libcairo2-doc,
- libcairo-script-interpreter2 (= ${binary:Version})
+Suggests: libcairo2-doc
Description: Development files for the Cairo 2D graphics library
Cairo is a multi-platform library providing anti-aliased
vector-based rendering for multiple target backends.
diff --git a/perf/Makefile.am b/perf/Makefile.am
index 6a1b72c..f64444f 100644
--- a/perf/Makefile.am
+++ b/perf/Makefile.am
@@ -10,6 +10,18 @@ AM_CPPFLAGS = \
AM_LDFLAGS = $(CAIRO_LDFLAGS)
+if CAIRO_HAS_PERF_UTILS
+bin_PROGRAMS = cairo-perf-micro \
+ cairo-perf-trace \
+ cairo-perf-diff-files \
+ cairo-perf-print \
+ cairo-perf-chart \
+ cairo-perf-compare-backends
+if HAVE_GTK
+bin_PROGRAMS += cairo-perf-graph-files
+endif
+endif
+
EXTRA_PROGRAMS += cairo-perf-micro \
cairo-perf-trace \
cairo-perf-diff-files \