summaryrefslogtreecommitdiff
path: root/meson_options.txt
diff options
context:
space:
mode:
authorDylan Baker <dylan.c.baker@intel.com>2023-06-12 10:53:58 -0700
committerMarge Bot <emma+marge@anholt.net>2023-06-12 23:07:00 +0000
commitce07aabab124e14a47f13f9fb734d9502cf527b5 (patch)
treeab762519485bf09e22484b6ec70b14102483fff0 /meson_options.txt
parentb717a438261ad53bcc8c27e8a36cfd7e7a7b579f (diff)
meson: Key whether to build batch decoder on expat
Instead of on Android. Which allows an end user to turn off expat without breaking or disabling Intel support. I've additionally refactored to separate expat and xmlconfig a bit more in the root meson.build This does make expat a hard dependency for building Intel tools, despite the fact that only aubinator actually requires it. This simplifies the build for the common case, and in the event that someone wants to build the Intel tools and doesn't have libexpat, they can fall back to the meson wrap for expat instead. fixes: 75276deebcf76f8fafa68f4e4ecb29768d98c764 closes: https://gitlab.freedesktop.org/mesa/mesa/-/issues/8791 Reviewed-by: Mark Janes <markjanes@swizzler.org> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/23605>
Diffstat (limited to 'meson_options.txt')
-rw-r--r--meson_options.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/meson_options.txt b/meson_options.txt
index 5984dc6d768..34a55ad7091 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -59,6 +59,14 @@ option(
)
option(
+ 'expat',
+ type : 'feature',
+ value : 'auto',
+ description : 'Controls the use of expat. ' +
+ 'Cannot be disabled if xmlconfig is enabled.'
+)
+
+option(
'gallium-drivers',
type : 'array',
value : ['auto'],
@@ -649,6 +657,7 @@ option(
'the default driconf file is hardcoded into Mesa. ' +
'Requires expat.'
)
+
option (
'intel-xe-kmd',
type : 'feature',