summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorCaio Oliveira <caio.oliveira@intel.com>2023-06-14 22:35:23 -0700
committerMarge Bot <emma+marge@anholt.net>2023-06-20 03:43:41 +0000
commitcb588d5d6ee290ff8ea405ff3ee56a51bc1b2145 (patch)
treeb7d09a22b009fe675a16041d48093278e30fb037 /meson.build
parentbe3e4c8aaf1b2b9d257a7abd9c3d7ab43ecfdcc5 (diff)
compiler/clc: Move related NIR passes to the common mesa clc
These were historically in the spirv+nir combo, but the common mesa clc is a better home for them. Reviewed-by: Jesse Natalie <jenatali@microsoft.com> Acked-by: Nora Allen <blackcatgames@protonmail.com> Acked-by: Lionel Landwerlin <lionel.g.landwerlin@intel.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/23667>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 2 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 5238d6f0640..14660219a79 100644
--- a/meson.build
+++ b/meson.build
@@ -278,7 +278,6 @@ else
with_intel_vk_rt = false
endif
with_clc = with_microsoft_clc or with_intel_clc
-with_libclc = with_clc
with_spirv_to_dxil = get_option('spirv-to-dxil')
if host_machine.system() == 'darwin'
@@ -751,7 +750,7 @@ if _opencl != 'disabled'
error('The Clover OpenCL state tracker requires rtti')
endif
- with_libclc = true
+ with_clc = true
with_gallium_opencl = true
with_opencl_icd = _opencl == 'icd'
else
@@ -772,11 +771,10 @@ if with_gallium_rusticl
add_languages('rust', required: true)
with_clc = true
- with_libclc = true
endif
dep_clc = null_dep
-if with_libclc
+if with_clc
dep_clc = dependency('libclc')
endif