summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJosé Roberto de Souza <jose.souza@intel.com>2022-12-19 09:28:00 -0800
committerMarge Bot <emma+marge@anholt.net>2023-03-03 05:25:35 +0000
commit7d34ec4691d7c713e0dff947314c1954a3c76f1b (patch)
tree41c32c7dfd09d4b80eed6f9eb80f72041e9d78e0 /meson.build
parentee510e2c50497845ab156c24dfd64033673e51b6 (diff)
intel: Add Meson parameter to enable Xe KMD support
The plan is to compile all the Xe files but in run time it will fail to detect the KMD loaded and it will fall back to software rendering(if build). Compiling Xe files makes sure newer commits don't break Xe even if developers don't have Xe enabled in their build folder. Signed-off-by: José Roberto de Souza <jose.souza@intel.com> Reviewed-by: Lionel Landwerlin <lionel.g.landwerlin@intel.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/21368>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 2c7c4aaa59e..2b1b68f87b9 100644
--- a/meson.build
+++ b/meson.build
@@ -1428,6 +1428,10 @@ if with_any_intel and ['x86', 'x86_64'].contains(host_machine.cpu_family())
pre_args += '-DSUPPORT_INTEL_INTEGRATED_GPUS'
endif
+if get_option('intel-xe-kmd').enabled()
+ pre_args += '-DINTEL_XE_KMD_SUPPORTED'
+endif
+
# Determine whether or not the rt library is needed for time functions
if host_machine.system() == 'windows' or cc.has_function('clock_gettime')
dep_clock = null_dep