summaryrefslogtreecommitdiff
path: root/hw/xwayland/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'hw/xwayland/meson.build')
-rw-r--r--hw/xwayland/meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/hw/xwayland/meson.build b/hw/xwayland/meson.build
index d2791fe14..b619a66a7 100644
--- a/hw/xwayland/meson.build
+++ b/hw/xwayland/meson.build
@@ -18,6 +18,7 @@ protodir = protocols_dep.get_pkgconfig_variable('pkgdatadir')
pointer_xml = join_paths(protodir, 'unstable', 'pointer-constraints', 'pointer-constraints-unstable-v1.xml')
relative_xml = join_paths(protodir, 'unstable', 'relative-pointer', 'relative-pointer-unstable-v1.xml')
tablet_xml = join_paths(protodir, 'unstable', 'tablet', 'tablet-unstable-v2.xml')
+kbgrab_xml = join_paths(protodir, 'unstable', 'xwayland-keyboard-grab', 'xwayland-keyboard-grab-unstable-v1.xml')
client_header = generator(scanner,
output : '@BASENAME@-client-protocol.h',
@@ -30,9 +31,11 @@ code = generator(scanner,
srcs += client_header.process(relative_xml)
srcs += client_header.process(pointer_xml)
srcs += client_header.process(tablet_xml)
+srcs += client_header.process(kbgrab_xml)
srcs += code.process(relative_xml)
srcs += code.process(pointer_xml)
srcs += code.process(tablet_xml)
+srcs += code.process(kbgrab_xml)
xwayland_glamor = []
if gbm_dep.found()