summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorFrediano Ziglio <fziglio@redhat.com>2017-10-20 11:28:15 +0100
committerFrediano Ziglio <fziglio@redhat.com>2017-10-20 11:28:15 +0100
commita8fc6814b656221a6d640b4675e990c3e74a2403 (patch)
treefb8c7f19ceff0a0435539093fd8bb01d485fdeb6 /Makefile.am
Initial public commit
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..9224646
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,23 @@
+NULL =
+SUBDIRS = \
+ include/spice-streaming-agent \
+ src \
+ $(NULL)
+
+# this will start the program for each user session
+xdgautostartdir = $(sysconfdir)/xdg/autostart
+xdgautostart_DATA = $(top_srcdir)/data/spice-streaming.desktop
+
+# this will start the program for the login session
+gdmautostartdir = $(datadir)/gdm/greeter/autostart
+gdmautostart_DATA = $(top_srcdir)/data/spice-streaming.desktop
+
+pkgconfigdir = $(datadir)/pkgconfig
+pkgconfig_DATA = spice-streaming-agent.pc
+
+EXTRA_DIST = \
+ spice-streaming-agent.spec \
+ spice-streaming-agent.pc \
+ LICENSE \
+ data/spice-streaming.desktop \
+ $(NULL)