summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@redhat.com>2010-12-30 16:52:52 +0100
committerMarc-André Lureau <marcandre.lureau@redhat.com>2010-12-30 16:52:52 +0100
commitfa47ed1229b765de224ed5c11ce90fae3f59ee50 (patch)
tree5705ba82ee94338eead67c86ccf581c5adecbf53 /Makefile.am
parent359a49ff3925a286edeb9b9ea156bb3b203ece04 (diff)
build: win32: add spicy-for-windows.exe scripts
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 4ac0f82..5a9d354 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -56,5 +56,19 @@ $(top_srcdir)/.version:
DISTCHECK_CONFIGURE_FLAGS = --enable-introspection --enable-werror --enable-gtk-doc
+spicy-for-windows.exe:
+ PATH=$$PATH:/usr/i686-pc-mingw32/sys-root/mingw/bin/:/usr/i686-pc-mingw32/sys-root/mingw/lib \
+ nsiswrapper --run --name "spicy" --outfile "spicy-for-windows.exe" --with-gtk \
+ /usr/i686-pc-mingw32/sys-root/mingw/bin/spicy.exe /usr/i686-pc-mingw32/sys-root/mingw/bin/snappy.exe \
+ /usr/i686-pc-mingw32/sys-root/mingw/bin/libpangoft2-1.0-0.dll \
+ /usr/i686-pc-mingw32/sys-root/mingw/bin/libgdk_pixbuf-2.0-0.dll \
+ /usr/i686-pc-mingw32/sys-root/mingw/bin/libgdk-win32-2.0-0.dll \
+ /usr/i686-pc-mingw32/sys-root/mingw/bin/gst-*.exe \
+ /usr/i686-pc-mingw32/sys-root/mingw/lib/gstreamer-0.10/libgstaudio*.dll \
+ /usr/i686-pc-mingw32/sys-root/mingw/lib/gstreamer-0.10/libgstdirectsoundsink.dll \
+ /usr/i686-pc-mingw32/sys-root/mingw/lib/gstreamer-0.10/libgstapp.dll \
+ /usr/i686-pc-mingw32/sys-root/mingw/lib/gstreamer-0.10/libgstautodetect.dll \
+ /usr/i686-pc-mingw32/sys-root/mingw/lib/gstreamer-0.10/libgstcoreelements.dll
+
-include $(top_srcdir)/git.mk