summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJonas Ådahl <jadahl@gmail.com>2014-03-12 22:08:42 +0100
committerKristian Høgsberg <krh@bitplanet.net>2014-03-12 14:55:22 -0700
commite0de3c2418fd754327eaffe1115857f1e99426fc (patch)
treea461601c6cc9ee4da5c1c545d58a4e018517af67 /configure.ac
parent0feb32e2f0292179d477357a2c253ae98130afff (diff)
Add libinput based input device backend
While disable by default, passing --enable-libinput-backend to ./configure switches the input backend in weston's drm, fbdev and rpi compositing backends to use libinput instead of udev-seat.c, evdev.c and friends. When enabled, weston now also depends on libinput >= 0.1.0. Signed-off-by: Jonas Ådahl <jadahl@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 00d71234..4db0ed14 100644
--- a/configure.ac
+++ b/configure.ac
@@ -153,6 +153,16 @@ if test x$enable_drm_compositor = xyes; then
PKG_CHECK_MODULES(DRM_COMPOSITOR, [libudev >= 136 libdrm >= 2.4.30 gbm mtdev >= 1.1.0])
fi
+
+AC_ARG_ENABLE(libinput-backend, [ --enable-libinput-backend],,
+ enable_libinput_backend=no)
+AM_CONDITIONAL([ENABLE_LIBINPUT_BACKEND], [test x$enable_libinput_backend = xyes])
+if test x$enable_libinput_backend = xyes; then
+ AC_DEFINE([BUILD_LIBINPUT_BACKEND], [1], [Build the libinput input device backend])
+ PKG_CHECK_MODULES(LIBINPUT_BACKEND, [libinput >= 0.1.0])
+fi
+
+
PKG_CHECK_MODULES(COMPOSITOR, [$COMPOSITOR_MODULES])
AC_ARG_ENABLE(wayland-compositor, [ --enable-wayland-compositor],,
@@ -506,6 +516,8 @@ AC_MSG_RESULT([
FBDEV Compositor ${enable_fbdev_compositor}
RDP Compositor ${enable_rdp_compositor}
+ libinput Backend ${enable_libinput_backend}
+
Raspberry Pi BCM headers ${have_bcm_host}
Build Clients ${enable_clients}