summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJavier Jardón <jjardon@gnome.org>2011-02-09 00:36:37 +0000
committerChris Wilson <chris@chris-wilson.co.uk>2011-02-09 11:46:19 +0000
commit9184af921bc2f332fcb6c9b47001414378eab8e2 (patch)
tree87961a6fa848e00fffc3460206fb8aa638eb9d6c /configure.ac
parent6e721e098b9181e8e77e314f966729d28e705582 (diff)
Update autotools configuration
Use new libtool syntax and silent-rules to silent the build output a bit (linux-like)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 12 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 13a801a8..5a1baacd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,18 +21,24 @@
# Process this file with autoconf to produce a configure script
# Initialize Autoconf
-AC_PREREQ([2.60])
+AC_PREREQ([2.63])
AC_INIT([xf86-video-intel],
[2.14.0],
[https://bugs.freedesktop.org/enter_bug.cgi?product=xorg],
[xf86-video-intel])
AC_CONFIG_SRCDIR([Makefile.am])
AC_CONFIG_HEADERS([config.h])
-AC_CONFIG_AUX_DIR(.)
+AC_CONFIG_AUX_DIR([build-aux])
+AC_CONFIG_MACRO_DIR([m4])
# Initialize Automake
-AM_INIT_AUTOMAKE([foreign dist-bzip2])
-AM_MAINTAINER_MODE
+AM_INIT_AUTOMAKE([1.10 foreign dist-bzip2])
+AM_MAINTAINER_MODE([enable])
+
+# Support silent build rules, requires at least automake-1.11. Disable
+# by either passing --disable-silent-rules to configure or passing V=1
+# to make
+m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
# Require X.Org macros 1.8 or later for MAN_SUBSTS set by XORG_MANPAGE_SECTIONS
m4_ifndef([XORG_MACROS_VERSION],
@@ -50,8 +56,8 @@ m4_ifndef([XORG_DRIVER_CHECK_EXT],
depending on your distribution, try package 'xserver-xorg-dev' or 'xorg-x11-server-devel'])])
# Initialize libtool
-AC_DISABLE_STATIC
-AC_PROG_LIBTOOL
+LT_PREREQ([2.2])
+LT_INIT([disable-static])
PKG_CHECK_MODULES(GEN4ASM, [intel-gen4asm >= 1.1], [gen4asm=yes], [gen4asm=no])
AM_CONDITIONAL(HAVE_GEN4ASM, test x$gen4asm = xyes)