summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorU. Artie Eoff <ullysses.a.eoff@intel.com>2010-12-21 15:10:41 -0700
committerCarl Worth <cworth@cworth.org>2010-12-21 14:19:13 -0800
commit90576f95f35e528fa2c667df162c5dc7ec98975d (patch)
tree2ab3def94c924ba7b7c7949d0a04b3ca072c981b /configure.ac
parent1ac2e04023f84dbf1f3db2ecad1cadd159aa614d (diff)
configure: updated m4 macro check in configure.ac
Added m4 check for XORG_DRIVER_CHECK_EXT macro definition. Updated m4 fatal messages to give better hint on how to resolve error when xorg macros are missing. Previously, configure would continue in spite of the missing macros and the build would fail for syntax errors.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 05848ea6..e6517e65 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,10 +36,16 @@ AM_MAINTAINER_MODE
# Require X.Org macros 1.8 or later for MAN_SUBSTS set by XORG_MANPAGE_SECTIONS
m4_ifndef([XORG_MACROS_VERSION],
- [m4_fatal([must install xorg-macros 1.8 or later before running autoconf/autogen])])
+ [m4_fatal([must install xorg-macros 1.8 or later before running autoconf/autogen.
+ Try "apt-get install xutils-dev" or "yum install xorg-x11-util-macros"])])
XORG_MACROS_VERSION(1.8)
XORG_DEFAULT_OPTIONS
+# Require X.Org server macros (i.e. XORG_DRIVER_CHECK_EXT) to check for required modules
+m4_ifndef([XORG_DRIVER_CHECK_EXT],
+ [m4_fatal([must install xorg-server macros before running autoconf/autogen.
+ Try "apt-get install xserver-xorg-dev" or "yum install xorg-x11-server-devel"])])
+
# Initialize libtool
AC_DISABLE_STATIC
AC_PROG_LIBTOOL