summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2011-09-15 17:52:45 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2011-09-15 18:00:07 +0100
commit72ca1fdf2fea80ff4cf003bb025424d15d8bac58 (patch)
tree17fb32e36ba3d8413445776d58ea67c89b9aa6b0 /configure.ac
parent544a4167c156eac7b630f90ddef30a6f00829835 (diff)
configure: Introduce --with-builderstring
Julien Cristau disliked my broadcasting of the git tree used to build his distribution package as it bore little relevance to his users. As it is only useful for people installing their own drivers (as a means of sanity checking that they are running the right driver), we introduce the --with-builderstring idiom borrowed from the xserver. This allows the builder to override the use of `git describe` and either leave it blank or to fill it with something useful for their own purposes. Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 089fbdb0..e2690069 100644
--- a/configure.ac
+++ b/configure.ac
@@ -67,6 +67,26 @@ if test -e .git; then
fi
AM_CONDITIONAL(HAVE_DOT_GIT, test x$dot_git = xyes)
+# If so, we include the git description in our logs for sanity checking.
+#
+# However, for people not running their own drivers this is just noise.
+# So we copy the xserver's builderstring idiom to allow for this to be
+# overridden and perhaps replaced with something more useful.
+AC_ARG_WITH(builderstring,
+ AS_HELP_STRING([--with-builderstring=BUILDERSTRING],
+ [Additional builder string (default: use git describe)]),
+ [BUILDERSTRING="$withval"],
+ [BUILDERSTRING="x-magic-git-describe"])
+
+if test "x$BUILDERSTRING" = xx-magic-git-describe -a x$dot_git = xyes; then
+ AC_DEFINE(USE_GIT_DESCRIBE, 1, [Use automagic builder description])
+else
+ if test "x$BUILDERSTRING" != x -a "x$BUILDERSTRING" != xno -a "x$BUILDERSTRING" != xx-magic-git-describe; then
+ AC_DEFINE_UNQUOTED(BUILDER_DESCRIPTION, ["$BUILDERSTRING"], [Builder description])
+ fi
+fi
+
+
PKG_CHECK_MODULES(GEN4ASM, [intel-gen4asm >= 1.2], [gen4asm=yes], [gen4asm=no])
AM_CONDITIONAL(HAVE_GEN4ASM, test x$gen4asm = xyes)