summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPing Cheng <pinglinux@gmail.com>2009-08-03 13:15:47 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2009-08-03 13:57:11 +1000
commit6c5b33444b2e6d7acacaf200dbf7bafc676328cb (patch)
tree026d6292a7d800b6f9d6d07caf658c208280f577 /Makefile.am
parent0e7c5819592680b8f75e29ad3d97f85bf4fd8da0 (diff)
Set up the default xf86-input-* directory structure, autotool.
This version does not build as-is due to missing include files and headers that are about to be purged anyway. It does pass the autoconf stage. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am42
1 files changed, 37 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index d2909a6..3fbaa1b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,8 +1,40 @@
-SUBDIRS = src
+# Copyright 2005 Adam Jackson.
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# on the rights to use, copy, modify, merge, publish, distribute, sub
+# license, and/or sell copies of the Software, and to permit persons to whom
+# the Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT. IN NO EVENT SHALL
+# ADAM JACKSON BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER
+# IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+# CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
-noinst_SCRIPT = wrapitup
+AUTOMAKE_OPTIONS = foreign
-x-includes:
- @sh mkxincludes
+# Ensure headers are installed below $(prefix) for distcheck
+DISTCHECK_CONFIGURE_FLAGS = --with-sdkdir='$${includedir}/xorg'
-EXTRA_DIST = GPL prebuilt/wacom_drv.o
+SUBDIRS = src man include
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = xorg-wacom.pc
+
+EXTRA_DIST = ChangeLog
+
+MAINTAINERCLEANFILES=ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ $(CHANGELOG_CMD)
+
+dist-hook: ChangeLog