summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2011-01-19 10:59:03 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2011-01-31 09:11:56 +1000
commit4bc52aba794c3054535e0c2af174b26144d39002 (patch)
tree7b63fcc23660ba28829623991f9e6e389a6080a7 /Makefile.am
parent23ed0b11c24582caa6465c8fa083e8e830ce6a75 (diff)
Add a testing framework for the driver.
This uses glib's testing framework provided glib-devel was available at configure time (same as the X server's testing framework). How this works: The wacom driver is recompiled for the testing framework and linked into the wacom-tests binary (there's a warning about that but ignore that). Since the .so uses a number of symbols from the Xorg binary, these are provided as stubs in fake-symbols.c. Additional binaries can be added through the check_PROGRAMS automake variable. The driver will be rebuild without static symbols for the test, allowing each function call to be tested. To run the tests, run 'make check'. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net> Acked-by: Ping Cheng <pinglinux@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 1e936d9..bf24997 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,7 +22,7 @@
DISTCHECK_CONFIGURE_FLAGS = --with-sdkdir='$${includedir}/xorg' \
--with-xorg-conf-dir='$${datadir}/X11/xorg.conf.d'
-SUBDIRS = conf src man include tools
+SUBDIRS = conf src man include tools test
MAINTAINERCLEANFILES = ChangeLog INSTALL
pkgconfigdir = $(libdir)/pkgconfig