summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 9 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 09f78eb..b284563 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,11 +2,11 @@ dnl required version of autoconf
AC_PREREQ([2.53])
dnl TODO: fill in your package name and package version here
-AC_INIT([gst-ducati],[0.10.0])
+AC_INIT([gst-ducati],[0.11.0])
dnl required versions of gstreamer and plugins-base
-GST_MAJORMINOR=0.10
-GST_REQUIRED=0.10.30
+GST_MAJORMINOR=0.11
+GST_REQUIRED=0.11.0
AC_CONFIG_SRCDIR([src/gstducati.c])
AC_CONFIG_HEADERS([config.h])
@@ -82,10 +82,10 @@ PKG_CHECK_MODULES(LIBDCE, [libdce >= 1.0.0])
dnl Check for the required version of GStreamer core (and gst-plugins-base)
dnl This will export GST_CFLAGS and GST_LIBS variables for use in Makefile.am
PKG_CHECK_MODULES(GST, [
- gstreamer-0.10 >= $GST_REQUIRED
- gstreamer-base-0.10 >= $GST_REQUIRED
- gstreamer-plugins-base-0.10 >= $GST_REQUIRED
- gstreamer-plugins-bad-0.10
+ gstreamer-$GST_MAJORMINOR >= $GST_REQUIRED
+ gstreamer-base-$GST_MAJORMINOR >= $GST_REQUIRED
+ gstreamer-plugins-base-$GST_MAJORMINOR >= $GST_REQUIRED
+ gstreamer-plugins-bad-$GST_MAJORMINOR
], [
AC_SUBST(GST_CFLAGS)
AC_SUBST(GST_LIBS)
@@ -93,8 +93,8 @@ PKG_CHECK_MODULES(GST, [
AC_MSG_ERROR([
You need to install or upgrade the GStreamer development
packages on your system. On debian-based systems these are
- libgstreamer0.10-dev and libgstreamer-plugins-base0.10-dev.
- on RPM-based systems gstreamer0.10-devel, libgstreamer0.10-devel
+ libgstreamer$GST_MAJORMINOR-dev and libgstreamer-plugins-base$GST_MAJORMINOR-dev.
+ on RPM-based systems gstreamer$GST_MAJORMINOR-devel, libgstreamer$GST_MAJORMINOR-devel
or similar. The minimum version required is $GST_REQUIRED.
])
])