summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJose Fonseca <jfonseca@vmware.com>2016-01-27 08:25:20 +0000
committerJose Fonseca <jfonseca@vmware.com>2016-01-27 08:27:07 +0000
commitc4ff127483c8dcefd9b65c8fea4ec7a87d6b02c8 (patch)
treeac62e8d6a946e6c95f6cb5591d17cbfcded21de8 /CMakeLists.txt
parentfbceb852ace8e3e2d1d5bd2081eb1fa8b512cfa2 (diff)
cmake: Package all scripts.
Using a glob might fail to detect a new script, if there was no CMakeLists.txt change. However it seems less likely than me forgetting to manually add the scripts to the CMakeLists.txt. https://github.com/apitrace/apitrace/issues/416#issuecomment-174886761
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt26
1 files changed, 1 insertions, 25 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 37d9e653..f67405e6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -512,33 +512,9 @@ if (ENABLE_CLI)
add_subdirectory (inject)
endif ()
add_subdirectory (cli)
+ add_subdirectory (scripts)
endif ()
-##############################################################################
-# Scripts (to support the CLI)
-
-install (
- PROGRAMS
- scripts/highlight.py
- scripts/jsondiff.py
- scripts/profileshader.py
- scripts/retracediff.py
- scripts/snapdiff.py
- scripts/tracecheck.py
- scripts/tracediff.py
- scripts/unpickle.py
- DESTINATION ${SCRIPTS_INSTALL_DIR}
-)
-if (WIN32)
- install (
- PROGRAMS scripts/convert.py
- DESTINATION ${SCRIPTS_INSTALL_DIR}
- )
- install (
- FILES scripts/apitrace.PIXExp
- DESTINATION ${SCRIPTS_INSTALL_DIR}
- )
-endif ()
##############################################################################
# GUI