summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorZhigang Gong <zhigang.gong@linux.intel.com>2012-01-20 12:10:06 +0800
committerZhigang Gong <zhigang.gong@linux.intel.com>2012-01-29 16:40:49 +0800
commitf9b4bd8ab5643bbf82eb896c0ded381fb3b0c423 (patch)
tree33a4efbc5134141b0fb406b1f1b0c4c8f7b801a8 /configure.ac
parentf9bcc8909dae77e3936b98afba79a3618c629e1c (diff)
glamor_egl: Add support for the platform doesn't have gbm.
Maybe we should use eglGetDisplayDRM to get display, but current PVR's driver is using eglGetDisplay. Signed-off-by: Peng Li <peng.li@intel.com> Signed-off-by: Zhigang Gong <zhigang.gong@linux.intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e0723eb..f283d4f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -103,7 +103,10 @@ PKG_CHECK_MODULES(EGL, $LIBEGL, [EGL=yes], [EGL=no])
AM_CONDITIONAL([EGL], [test "x$EGL" = xyes])
if test "x$EGL = xyes"; then
- PKG_CHECK_MODULES(GBM, $LIBGBM)
+ PKG_CHECK_MODULES(GBM, $LIBGBM, [GBM=yes], [GBM=no])
+ if test "x$GBM" = xyes; then
+ AC_DEFINE(GLAMOR_HAS_GBM, 1, [Use GBM.])
+ fi
fi
AC_OUTPUT([Makefile